Macina_searchbox: Button funktioniert nicht [Gelöst]

  • chrickenh chrickenh
    Jedi-Ritter
    0 x
    142 Beiträge
    0 Hilfreiche Beiträge
    21. 09. 2012, 19:24

    Hallo,
    ich verwende ein einem Projekt (v. 4.7.0) die macina_searchbox 2.2.0.
    Die funktioniert auch ganz gut, bis auf ein Detail.
    Wenn ich die Suche eingebe und Return drücke, funktioniert alles.
    Benutze ich aber den Button, dann passiert nichts.

    Es liegt kein Element über dem Button, das hab ich schon getestet.

    Der generierte HTML-Code sieht so aus:

    1. <div class="macina">
    2. <form action="diese-seite/suche/" method="post" name="searchform" id="searchform">
    3. <div class="eingabe">
    4. <input name="tx_indexedsearch[sword]" type="text" />
    5. </div>
    6. <div class="suchen">
    7. <input name="tx_indexedsearch[submit_button]" type="button" value="Suche" />
    8. <input type="hidden" name="tx_indexedsearch[_sections]" value="0" />
    9. <input type="hidden" name="tx_indexedsearch[pointer]" value="0" />
    10. <input type="hidden" name="tx_indexedsearch[ext]" value="0" />
    11. <input type="hidden" name="tx_indexedsearch[lang]" value="0" />
    12. </div>
    13. </form>
    14. </div>

    Das Setup zur Searchbox sieht so aus:

    1. ## Searchbox
    2. lib.field_searchbox < plugin.tx_macinasearchbox_pi1
    3. plugin.tx_macinasearchbox_pi1 {
    4. pidSearchPage = 218
    5. }

    Fehlt sonst noch etwas?

    Ich hoffe, jemand weiß Rat.
    Danke
    Chrickenh


  • 1
  • chrickenh chrickenh
    Jedi-Ritter
    0 x
    142 Beiträge
    0 Hilfreiche Beiträge
    22. 09. 2012, 11:04

    Hallo,

    es hat sich erledigt.
    Ich habe den Button als type="button" angelegt, einem Tutorial folgend.
    Er muss aber type="submit" sein, dann klappts auch.

    Vielen Dank fürs Lesen
    Chrickenh

  • 1