Auslesen des News-Title per TS und RealURL [Gelöst]

  • Ebis Ebis
    TYPO3-Anwärter
    0 x
    4 Beiträge
    0 Hilfreiche Beiträge
    19. 09. 2012, 14:48

    Hallo

    Ich lese sonst den Titel der jeweiligen News mittels TYPOScript aus und gebe diesen dann anstatt der Überschrift aus.

    Das funktioniert (normalerweise) so:

    1. [globalVar = GP:tx_ttnews|tt_news > 0]
    2. temp {
    3. FOO = RECORDS
    4. FOO {
    5. tables = tt_news
    6. source.data = GPvar:tx_ttnews[tt_news]
    7. conf {
    8. tt_news = TEXT
    9. tt_news.field = title
    10. }
    11. }
    12. }
    13. [global]

    Seit neustem funktioniert das nicht mehr (ausgegeben wird gar nichts)(Verwendet wird die tt_news in der Version 3.2.1 mit TYPO3 4.6.12) Wraped man das Ganze, dann wird NUR der Wrap ausgegeben.

    Ebenso funktioniert das auslesen der UID der News nicht mit der Extension genericnewsmarker

    Der Marker lautet ###GENERIC_UID###

    Per TS so konfiguriert:

    1. tt_news {
    2. genericmarkers {
    3. uid = RECORDS
    4. uid {
    5. tables = tt_news
    6. source.data = GPvar:tx_ttnews[tt_news]
    7. conf {
    8. tt_news = TEXT
    9. tt_news {
    10. field = uid
    11. wrap = #|
    12. }
    13. }
    14. }
    15. }
    16. }
    17. }

    Ist es eventuell möglich, dass es da einen Zusammenhang mit der Verwendung von RealURL gibt. Können DB Abrfragen, bzw Ausgaben mit RealURL auf oben gezeigte Weise nicht mehr realisiert werden? Wen dem so ist, wie geht es dann?


  • 1
  • LuP LuP
    Jedi-Meister
    0 x
    496 Beiträge
    1 Hilfreiche Beiträge
    19. 09. 2012, 15:33

    Hallo und Willkommen im Forum,

    die Lösung dafür kannst Du [url="http://www.typo3.net/forum/beitraege/sonstiges-2/111963/"]diesem Thread[/url] entnehmen.

    VG,
    LuP

  • Ebis Ebis
    TYPO3-Anwärter
    0 x
    4 Beiträge
    0 Hilfreiche Beiträge
    19. 09. 2012, 17:16

    Hallo,

    Vielen Dank!
    Funktioniert nun wieder.

  • 1