Kein PDF-Seiteninhalt nach Update von pdf_generator2 auf v 0.21.1

  • tommboogie tommboogi...
    Padawan
    0 x
    38 Beiträge
    0 Hilfreiche Beiträge
    19. 07. 2012, 11:38

    Hallo zusammen,

    nach dem Update von pdf_generator2 von Version 0.21.0 auf 0.21.1 bekomme keine Seiteninhalte mehr im PDF ausgegeben.
    Das PDF-Template wird korrekt per Templa Voila geladen, aber der Seiteninhalt fehlt.

    Seltsam ist, dass es ohne RealURL funktioniert z.B. http://meinedomain.de/index.php?id=13&type=202

    in der real_url.conf ist der type folgendermaßen definiert.

    1. ...
    2. 'fileName' => array (
    3. 'index' => array (
    4. 'druck.pdf' => array (
    5. 'keyValues' => array (
    6. 'type' => 202,
    7. )
    8. ),
    9. ...

    Ich verwende die TYPO3-Version 4.5.15 mit Templa Voila 1.5.4. und realurl 1.10.1
    Außerdem ist die Extension Pdf Generator for TemplaVoila - tv_pdfgen 1.1.1 installiert um TV-Inhalte ins PDF zu bekommen.

    Mein TS-Setup im Root-Template:

    1. pdf_generator = PAGE
    2. pdf_generator {
    3. config {
    4. admPanel = 0
    5. no_cache = 1
    6. pageGenScript = EXT:pdf_generator2/gen_pdf.php
    7. xmlprologue = none
    8. doctype = xhtml_trans
    9. xhtmlDoctype = xhtml_trans
    10. metaCharset = utf-8
    11. xhtml_cleaning = 0
    12. additionalHeaders = Content-type: application/pdf
    13. USERNAME_substToken =
    14. ftu = 0
    15. disableCharsetHeader = 1
    16. prefixLocalAnchors = 0
    17. no_user_int = 1
    18. }
    19. typeNum = 202
    20. }

    Zur Vorgehensweise beim Update: Ich habe pdf_generator2 und tv_pdfgen deinstalliert und zuerst pdf_generator2 und danach tv_pdfgen installiert.

    Wie gesagt, vor dem Update hat alles funktioniert :(

    Hat einer eine Idee?

    Danke Boogie


  • 1
  • tommboogie tommboogi...
    Padawan
    0 x
    38 Beiträge
    0 Hilfreiche Beiträge
    26. 10. 2015, 12:27

    Bin mittlerweile auf web2pdf umgestiegen, da pdf_generator2 unter TYPO3 6.2 nicht läuft.

  • 1