18. 07. 2012, 16:07

Hallo!

Wenn ich ein Kontaktformular ausfülle und dort in der Textarea Zeilenumbrüche schreibe (äh, also die enter-Taste drücke), werden diese in der Mail als <br /> eingefügt. Ich bekomme das <br /> einfach nicht weg.

Habe das Manual gelesen und in Google gesucht, bin aber noch nicht auf eine Lösung gekommen. Mit dem neuen Extbase-Code komme ich leider (noch) nicht klar, so dass mir ein Blick in den Code leider auch nicht weiterhalf.

Wie bekomme ich die Zeilenumbrüche weg? Was muss ich einstellen?

Meine Config (Teile daraus, Auslassungen = ...):

  1. enctype = multipart/form-data
  2. method = post
  3. prefix = tx_form
  4. confirmation = 1
  5. postProcessor {
  6. 1 = mail
  7. 1 {
  8. recipientEmail = xx@zz.de
  9. senderEmailField = email
  10. senderNameField = fullName
  11. subject = Meine Anfrage zum Thema
  12.  
  13. messages {
  14. success = Ihre Anfrage wurde verschickt!
  15. error = Leider ist beim Senden Ihrer Nachricht ein Fehler aufgetreten. Bitte versuchen Sie es erneut.
  16. }
  17. }
  18. }
  19. 10 = SELECT
  20. 10 {
  21. name = gender
  22. label {
  23. value = Anrede
  24. }
  25. 10 = OPTION
  26. 10 {
  27. data = Frau
  28. }
  29. 20 = OPTION
  30. 20 {
  31. data = Herr
  32. }
  33. }
  34. ...
  35. 60 = TEXTAREA
  36. 60 {
  37. cols = 40
  38. rows = 9
  39. name = 9
  40. label {
  41. value = Anliegen
  42. }
  43. }
  44. 70 = SUBMIT
  45. 70 {
  46. name = 10
  47. value = Anfrage abschicken
  48. }
  49. rules {
  50. ...
  51. }

Vielen Dank schon mal für Tipps und Anregegungen!