Dateilink-Problem

  • jochla jochla
    Jedi-Ritter
    0 x
    128 Beiträge
    0 Hilfreiche Beiträge
    26. 06. 2012, 12:29

    Hallo,

    als erstes bitte ich um Nachsicht, weil ich dieses Problem schon [url=http://www.typo3forum.net/forum/typo3-4-x-rich-text-editor/56476-probelm-dateilinks-externe-links-gerendert.html]hier[/url] und in der TYPO3-german Mailinglist gepostet habe. Aber die Zeit drängt und ich konnte das Problem bisher noch nicht lösen. Danke für's Verständnis.

    Wenn ich im RTE einen Dateilink setze wird dieser als externer Link in der DB gespeichert und gerendert (class=download).

    Ich verstehe nicht, warum ein Dateilink mit dem Domainteil in der Datenbank gespeichert wird. Macht doch eigentlich gar keinen Sinn!? Denn wenn es ein externes Dokument wäre würde ich doch auch einen externen Link anlegen. Aber ein Dateilink müsste m.E. doch immer ein interner Link sein, oder?

    An welchen Schrauben muss ich drehen, damit ein Dateilink als "interner Link" behandelt wird!?

    Gruß, Johannes.


  • 1
  • jochla jochla
    Jedi-Ritter
    0 x
    128 Beiträge
    0 Hilfreiche Beiträge
    02. 07. 2012, 09:41

    So, nun habe ich am Wochenende die aktuelle TYPO3 Version 4.7.1 installiert (Update). Trotzdem hat sich nichts verändert. Dateilinks werden immer noch als externe Links in der Datenbank gespeichert:

    <link http://www.domain.de/fileadmin/pdf/dokument.pdf _blank download>Linktext</link>

    In der RTE-Code-Ansicht sieht das so aus:

    <a href="http://www.domain.de/fileadmin/pdf/dokument.pdf" target="_blank" class="download" data-htmlarea-external="1">Linktext</a>

    Irgendwo muss der Fehler doch liegen. Hat niemand eine Idee?

  • 1