Seitentitel bei nicht vorhandenen News [Gelöst]

  • SirRuddy SirRuddy
    R2-D2
    0 x
    119 Beiträge
    0 Hilfreiche Beiträge
    03. 06. 2012, 20:11

    Hi,

    ich gebe bei tt_news den Seitentitel wie folgt aus.

    1. # Nachrichtentitel rendern
    2. nachrichtentitel = RECORDS
    3. nachrichtentitel {
    4. source = {GPvar:tx_ttnews|tt_news}
    5. source.insertData = 1
    6. tables = tt_news
    7. conf.tt_news >
    8. conf.tt_news = TEXT
    9. conf.tt_news.field = title
    10. }
    11.  
    12. # Nachrichtentitel als title-Tag ausgeben
    13. page.headerData.10 >
    14. page.headerData.10 < nachrichtentitel
    15. page.headerData.10.wrap = <title>| - Name meiner Seite</title>

    Nun kommt es aber vor das News gelöscht werden. Den Link gibt es dann aber bei Google (oder sonstwo) noch. Klick ein User drauf, kommt das Typische: [i]Keine News ID übergeben[/i], von tt_news.

    Nun habe ich den folgenden Snippet gefunden:

    1. seite.meta {
    2. author.field = author
    3. author.ifEmpty.cObject {
    4. value = Autoren Name
    5. }
    6. }

    ...fand ich einleuchtend, und dachte mir das muss doch auch so gehen:

    1. nachrichtentitel.conf.tt_news.ifEmpty.cObject = TEXT
    2. nachrichtentitel.conf.tt_news.ifEmpty.cObject = TEXT.value = Mein Text

    ...geht aber nicht. Hat einer von Euch einen Tipp für mich, wie ich den Seitentitel auf: Error 404 bekommen kann? Ich habe ansonsten im Netzt dazu keine brauchbare Lösung gefunden.

    Gruß
    SirRuddy


  • anderlk anderlk
    R2-D2
    0 x
    112 Beiträge
    1 Hilfreiche Beiträge
    27. 06. 2012, 16:37

    Hallo SirRuddy,
    du darfst das TS natürlich nur in Deine [b]News Single Seite[/b] einbauen. Auf anderen Seiten gibt es ja quasi keinen tt_news parameter, und somit gibts auch immer 404.

    Gruß Anderl

  • SirRuddy SirRuddy
    R2-D2
    0 x
    119 Beiträge
    0 Hilfreiche Beiträge
    27. 06. 2012, 18:10

    OK! Habe ich gemacht, und soweit scheint auch alles in Ordnung zu sein. Allerdings wenn ich jetzt einen 404 provoziere, bekomme ich im Browser folgende Fehlermeldung:

    [i]Diese Webseite weist eine Weiterleitung auf.
    Die Webseite unter [b]http://www.meine-seite.de/aktuelle-news/ansicht-aktuelles/datum/2009/06/15/%7B$baseurl%7Derror404.html[/b] hat zu viele Umleitungen erzeugt. Das Löschen Ihrer Cookies für diese Website oder das Zulassen von Drittanbieter-Cookies könnte das Problem möglicherweise beheben. Sollte sich das Problem damit nicht beheben lassen, liegt eventuell ein Serverkonfigurationsfehler und kein Problem mit Ihrem Computer vor.
    Vorschläge:
    Laden Sie diese Webseite später erneut.
    Weitere Informationen zu diesem Problem.
    Fehler 310 (net::ERR_TOO_MANY_REDIRECTS): Zu viele Umleitungen.[/i]

    Das ...%7B$baseurl%7Derror404.html am Ende sieht auch nicht so aus als sollte es dort sein. Kann es sein, dass es an der RealURL-Config liegt?

    Gruß
    SirRuddy