SOLR Your site was unable to contact the Apache Solr server. [Gelöst]

  • homy homy
    Padawan
    0 x
    52 Beiträge
    1 Hilfreiche Beiträge
    05. 04. 2012, 13:58

    Hallo,

    versuche gerade SOLR Plugin für Typo3 zum laufen zu bekommen.

    Nach anfänglichen Schwierigkeiten, scheint soweit die SOLR Installation mit Tomcat zu laufen. Die Cores sind von Example Multicore kopiert und nach core_en umbenannt. Da ich ein Multilang System habe und er anfangs ein wenig Probleme mit den verschieden Corenames gemacht hat, wollte ich es erst einmal bei der Standardeinstellung core_en belassen.

    Zugriff auf core_en hab ich via: domain.de:8080/solr/core_en/admin/

    Über die Typo3 Extension solradmin 1.1.2 hab ich auch Zugriff auf meine Core.

    Doch im Statusbericht kommt die Meldung:
    Apache Solr

    1. Your site was unable to contact the Apache Solr server.
    2.  
    3. Site: Company (pid: 2, language: Deutsch) - domain.de:8080/solr/core_en/
    4. Scheme: http
    5. Host: domain.de
    6. Port: 8080
    7. Path: /solr/core_en/

    Und auch das eigentlich wichtige indexzieren scheitert mit dem Fehler Exception 'Exception' with message 'No Solr instance available while trying to index a page.'

    Jedoch zeigt mir der Tomcat Manager 270 aktive Session an.

    Apache Tomcat 7.0.26
    jdk 1.7.0_03-b04
    Solr 3.5.0
    Typo3 4.5.14

    Fopen ist aktiviert!

    Weiß jmd. die Lösung ;) oder hat nen gutes Tutorial, dass die Installation nochmal schritt für schritt erklärt??

    Vielen Dank!


  • 1
  • LuP LuP
    Jedi-Meister
    0 x
    496 Beiträge
    1 Hilfreiche Beiträge
    05. 04. 2012, 15:54

    Hallo,

    folgende Punkte solltest Du mal prüfen:

    - php.ini

    safe_mode = Off
    allow_url_fopen = 1

    - cURL enabled

    im Install Tool
    curlUse aktivieren

    oder direkt in localconf.php
    $TYPO3_CONF_VARS['SYS']['curlUse'] = '1';

    Voraussetzungen:
    PHP-Modul cURL geladen (Debian: aptitude install php5-curl)
    oder cURL mit PHP kompiliert (--with-curl)

    VG,
    LuP

  • homy homy
    Padawan
    0 x
    52 Beiträge
    1 Hilfreiche Beiträge
    05. 04. 2012, 15:57

    Hi,

    jap vielen dank, hab ich gecheckt, curl hab ich deaktiviert, kann es aber auch wieder aktivieren.

    Brauch man nen PHPSolr Connector? Hab jetzt im Code der Extension und auf der PHP.net Seite geschaut, so wie es aussieht, scheitert es bei mir am PING.

  • homy homy
    Padawan
    0 x
    52 Beiträge
    1 Hilfreiche Beiträge
    05. 04. 2012, 16:24

    So es geht! JUUHHU und für die die via Suchanfrage hier her gelangt sind:

    FALLS JMD so dämlich ist wie ich #angry# und einfach die MultiCoreExamples kopier, bitte fügt in
    core_en/conf/solrconfig.xml oder core0/conf/solrconfig.xml folgendes im Abschnitt admin hinzu:

    1. <pingQuery>q=solr&amp;version=2.0&amp;start=0&amp;rows=0</pingQuery>
    2. <healthcheck type="file">server-enabled</healthcheck>

    Somit sieht dann der Adminblock wie folgt aus;
    1. <!-- config for the admin interface -->
    2. <admin>
    3. <defaultQuery>solr</defaultQuery>
    4. <pingQuery>q=solr&amp;version=2.0&amp;start=0&amp;rows=0</pingQuery>
    5. <healthcheck type="file">server-enabled</healthcheck>
    6. </admin>

  • LuP LuP
    Jedi-Meister
    0 x
    496 Beiträge
    1 Hilfreiche Beiträge
    05. 04. 2012, 17:19

    Kleiner Hinweis am Rande:

    die TYPO3-Erweiterung EXT:solr nutzt andere Schemas als die vom Example-Verzeichnis von Apache Solr. Die liegen in EXT:solr/resources/solr/typo3cores/conf/.

    VG,
    LuP

  • homy homy
    Padawan
    0 x
    52 Beiträge
    1 Hilfreiche Beiträge
    05. 04. 2012, 17:25

    Sau gut mitgedacht. Vielen Dank. Ist mir auch vor 10 min aufgeallen, als dann die ganzen Warings kamen :). Jetzt läuft alles, bist auf das indexzieren.

    Da bringt er mir den Fehler:
    Failed indexing page Index Queue item 2574

  • 1