sr_feuser_register 2.6.2/3 & TYPO3 4.5.10

  • Manuel.M Manuel.M
    TYPO3-Anwärter
    0 x
    4 Beiträge
    0 Hilfreiche Beiträge
    05. 03. 2012, 13:50

    Hallo!

    Ich habe folgendes Problem:
    Habe am Freitag aufgrund der Sicherheitslücke sr_feuser_register von Version 2.6.1 auf 2.6.3 upgedated.
    Leider werden seither keine Werte (mit Ausnahme der eMail Adresse) übergeben.
    Nach einem kleinen Downgrading Test konnte ich feststellen, dass der selbe Fehler auch bereits bei 2.6.2 auftritt.

    Das heißt:
    Der User, sowie der Admin, bekommen das Registrierungs eMail allerdings ohne die ausgefüllten Daten.
    Im System wird nun nur ein leerer User angelegt.

    Hat zufällig irgendjemand eine Ahnung, woran dies liegen bzw wie ich dieses Problem lösen könnte?

    Zur Info:
    Ich benutze TYPO3 4.5.10

    Danke & LG


  • 1
  • Gernott Gernott
    Jedi-Meister
    0 x
    271 Beiträge
    3 Hilfreiche Beiträge
    07. 03. 2012, 10:52

    Hallo Manuel,

    ich habe das gleiche Problem.
    In der Datenbank wird der User als leerer Eintrag angelegt. Alle Spalten bleiben leer :-(
    Bitte poste die Lösung wenn Du eine hast.

    Liebe Grüße
    Gernott

  • Gernott Gernott
    Jedi-Meister
    0 x
    271 Beiträge
    3 Hilfreiche Beiträge
    09. 03. 2012, 16:16

    Ich habe das Problem gelöst:
    Es liegt an der Extension srfeuserregister_t3secsaltedpw.
    Diese darf nicht mehr verwendet werden.
    Ich habe zum konvertieren der Passwörter den Task zum Passwörter konvertieren im Planer eingefügt und aktiviert.

  • Manuel.M Manuel.M
    TYPO3-Anwärter
    0 x
    4 Beiträge
    0 Hilfreiche Beiträge
    19. 03. 2012, 10:16

    Hat auch bei mir geklappt :D

    Vielen Dank!

  • mace2000 mace2000
    TYPO3-Anwärter
    0 x
    6 Beiträge
    0 Hilfreiche Beiträge
    29. 03. 2012, 15:33

    Danke Gernott! Hatte das gleiche Problem und wäre fast daran verweifelt. :'(

  • 1