Simulate Static und sr_sendcard

  • loremIpsum loremIpsu...
    Padawan
    0 x
    39 Beiträge
    0 Hilfreiche Beiträge
    27. 04. 2004, 11:06

    Liebe Gemeinde

    Ich habe bei mir (3.6.0 RC2) mit folgendem Code das Simulate Static eingerichtet:

    Setup:
    [code:1:5be9021a36]config.simulateStaticDocuments = 1
    config.simulateStaticDocuments_pEnc = md5
    config.simulateStaticDocuments_addTitle = 25[/code:1:5be9021a36]

    .htaccess:
    [code:1:5be9021a36]RewriteEngine on
    RewriteRule ^[^/]*.html$ /cms/index.php[/code:1:5be9021a36]

    Nun das Simulate Static funktioniert generell tip-top über die ganze Site, bloss bei den E-Cards (sr_sendcard) wird noch eine "hässliche" URL generiert:
    [URL]http://www.meinedomain.org/cms/Ecard.30.0.html?&tx_srsendcard_pi1%5Bcard_caption%5D=TestCard&tx_srsendcard_pi1%5Bcard_image%5D=sr_sendcard_e58fab381c.jpg&tx_srsendcard_pi1%5Bcard_image_path%5D=uploads%2Ftx_srsendcard%2F&tx_srsendcard_pi1%5Bcmd%5D=prompt&tx_srsendcard_pi1%5Bimage_height%5D=235&tx_srsendcard_pi1%5Bimage_width%5D=300[/URL]

    Hat jemand eine Ahnung an was das liegen könnte?

    Herzlichen Dank!
    Lorem


  • 1
  • Mathaka Mathaka
    T3PO
    0 x
    13 Beiträge
    0 Hilfreiche Beiträge
    29. 04. 2004, 18:26

    Ich habe genau das gleiche Problem ...
    Bei mir funktioniert das Sendcard Modul inbesondere die Email und der generierte Link überhaupt nicht richtig. Weder als HTML Email noch all Text Email

    Hat jemand dieses Script laufen und weis wie man diese Fehler beheben kann oder wie kriegt ihr das Script zum laufen?
    Was habtr ihr gemacht damit das richtig funktioniert?

  • loremIpsum loremIpsu...
    Padawan
    0 x
    39 Beiträge
    0 Hilfreiche Beiträge
    03. 09. 2004, 15:43

    Die Lösung ist (für jene dies interessiert...):

    1. Auf Typo3 3.6.2 upgraden
    2. Neuste Version der sr_sendcard Extension installieren (Vers. 1.0.1)
    3. Diesen Code zusätzlich ins TS-Setup einfügen:
    [code:1:42f6f4a262]simulateStaticDocuments_pEnc_onlyP = L,tx_srsendcard_pi1[cardid],tx_srsendcard_pi1[cmd][/code:1:42f6f4a262]

    ... und siehe da... Wunder geschehen :D

    Gruss
    Lorem

  • 0 x
    114 Beiträge
    0 Hilfreiche Beiträge
    18. 10. 2005, 13:13

    hallo hier noch eine bessere Lösung!!

    1. # Suchmaschinenoptimierung ECards
    2. config.simulateStaticDocuments_pEnc_onlyP = cHash,L,tx_srsendcard_pi1[cardid],tx_srsendcard_pi1[cmd],tx_srsendcard_pi1[card_caption],tx_srsendcard_pi1[card_image],tx_srsendcard_pi1[card_image_path],tx_srsendcard_pi1[image_height],tx_srsendcard_pi1[image_width],tx_srsendcard_pi1[selection_image],tx_srsendcard_pi1[selection_image_height],tx_srsendcard_pi1[selection_image_width]

  • 1