Linkformatierung wird nicht übernommen [Gelöst]

  • cherry cherry
    Jedi-Meister
    0 x
    415 Beiträge
    0 Hilfreiche Beiträge
    23. 01. 2012, 09:16

    Hallo,
    ich habe innerhalb eines Textes einen Link zu einer externen Seite. Nun habe ich folgende Ausgabe:

    1. <p class="text">Hier steh ein Text und so weiter. Dann kommt dieser Link zur Seite <a href="http://www.externeseite.de" target="_blank">www.externeseite.de</a>. Und hier steht wieder normaler Text.</p>

    Dieser Link wird mir aber nicht als formatierter Link ausgegeben sondern erscheint wie der Text.

    Die CSS dazu sieht so aus:

    1. a:link { color: #5273c4; text-decoration: underline }
    2. a:hover { color: #5273c4; text-decoration: underline }
    3. a:visited { color: #5273c4; text-decoration: underline }
    4. a:active { color: #5273c4; text-decoration: underline }
    5.  
    6. .text {font-family: Arial, Helvetica, sans-serif; font-size: 12px; color: #707070; text-decoration:none;}
    7. .text a:link {font-family: Arial, Helvetica, sans-serif; font-size: 12px; color: #707070; text-decoration:underline;}
    8. .text a:visited {font-family: Arial, Helvetica, sans-serif; font-size: 12px; color: #707070; text-decoration:none;}
    9. .text a:hover {font-family: Arial, Helvetica, sans-serif; font-size: 12px; color: #707070; text-decoration:none;}
    10. .text a:active {font-family: Arial, Helvetica, sans-serif; font-size: 12px; color: #707070; text-decoration:none;}

    Wie muss ich es denn nun richtig formatieren?


  • 1
  • LuP LuP
    Jedi-Meister
    0 x
    496 Beiträge
    1 Hilfreiche Beiträge
    23. 01. 2012, 09:42

    Hallo,

    vielleicht so:

    1. .text { font-family:Arial, Helvetica, sans-serif; font-size:12px; color: #707070; text-decoration:none;}
    2. .text a:link, .text a:hover, .text a:visited, .text a:active { color: #5273c4; text-decoration: underline }

    VG,
    LuP

  • cherry cherry
    Jedi-Meister
    0 x
    415 Beiträge
    0 Hilfreiche Beiträge
    23. 01. 2012, 10:10

    Ne, hat leider keine Veränderung gebracht, auch trotz geleertem Cache.

  • LuP LuP
    Jedi-Meister
    0 x
    496 Beiträge
    1 Hilfreiche Beiträge
    23. 01. 2012, 10:21

    auch den Browser-Cache geleert?

    VG,
    LuP

  • cherry cherry
    Jedi-Meister
    0 x
    415 Beiträge
    0 Hilfreiche Beiträge
    23. 01. 2012, 10:32

    Ja, auch der ist geleert. Es ändern sich alle Link die außerhalb (also z.B. aus einer Extension heraus erzeugt werden), aber leider nicht die, die innerhalb des RTE erzeugt sind.

  • Julian.Hofmann Julian.Ho...
    Flash Gordon
    0 x
    2862 Beiträge
    107 Hilfreiche Beiträge
    23. 01. 2012, 10:39

    Hallo.

    Sieht eigentlich richtig und logisch aus. Ich tippe drauf, dass die Ursache woanders zu suchen ist.

    Schau mal mit Firebug oder anderem Tool, welche CSS-Formatierung [u]wirklich[/u] für den Link greifen.

    Viel egrüße
    Julian

  • LuP LuP
    Jedi-Meister
    0 x
    496 Beiträge
    1 Hilfreiche Beiträge
    23. 01. 2012, 10:44

    mit Firebug (Firefox) kannst Du schnell herausfinden, welche CSS-Klasse dafür verantwortlich ist. Dann die unerwünschte Vererbung aufheben oder zusätzliche Klasse hinfügen.

    VG,
    LuP

  • LuP LuP
    Jedi-Meister
    0 x
    496 Beiträge
    1 Hilfreiche Beiträge
    23. 01. 2012, 10:46

    der Julian war ein Tick schneller :)

    VG,
    LuP

  • cherry cherry
    Jedi-Meister
    0 x
    415 Beiträge
    0 Hilfreiche Beiträge
    23. 01. 2012, 13:15

    D A N K E

    Es war die Klasse ".csc-textpic-text". Jetzt habe ich die in meiner CSS-Datei einfach nach meinen Bedürfnissen definiert, und jetzt passt es.

  • 1