Fehler in Verbindung mit showPBrowserText = 0

  • cermit cermit
    R2-D2
    0 x
    108 Beiträge
    0 Hilfreiche Beiträge
    11. 01. 2012, 17:26

    Hallo!

    Für einen Pagebrowser habe ich folgende Settings gemacht:

    1. usePiBasePagebrowser = 1
    2. pageBrowser {
    3. # Keine Anzeige von "Displaying results x to y"
    4. showResultCount = 0
    5. maxPages = 6
    6. # Seitenzahl, nicht Bereiche der Newsanzahlen zeigen
    7. showRange = 0
    8. # Anzeige von "Erste" und "Letze" unterdrücken
    9. showFirstLast = 1
    10. showPBrowserText = 0
    11. }

    Der Pagebrowser sieht dann wie folgt aus: <<Erste <Vorherige Page1 Page 2 ...

    Setze ich

    1. showPBrowserText = 1

    zeigt der Pagebrowser (wie dann auch erwartet): <<Erste <Vorherige Seite 1 Seite 2 Seite 3 ...

    Setzte ich

    1. showPBrowserText = 0 und showRange = 1

    zeigt er (wie erwartet): <<Erste <Vorherige 1-6 7-12 ...

    Sind Gründe bekannt oder habt Ihr Ideen, woher das ungewollte "Page" kommt und wie ich es wieder los werde?
    Vielen Dank
    Christoph


  • 1
  • user_dave user_dave
    Typ im Roten Hemd
    0 x
    3 Beiträge
    0 Hilfreiche Beiträge
    22. 01. 2013, 10:26

    [quote="cermit"]
    Sind Gründe bekannt oder habt Ihr Ideen, woher das ungewollte "Page" kommt und wie ich es wieder los werde?
    [/quote]

    Habe mit Typo3 6.0.0 und tt_news 3.4.0 exakt das gleiche Problem. Dürfte möglicherweise ein Bug in der Extension sein?
    Hast Du inzwischen schon eine Lösung gefunden? Ich bräuchte nämlich genau die Kombination aus

    1. showPBrowserText = 0
    2. showRange = 0

    LG, David

  • user_dave user_dave
    Typ im Roten Hemd
    0 x
    3 Beiträge
    0 Hilfreiche Beiträge
    22. 01. 2013, 10:52

    So, habe nun auf Umwegen das gewünschte Verhalten erreicht:

    1. #Pagebrowser Format
    2. plugin.tt_news.pageBrowser {
    3. showRange= 0
    4. showPBrowserText = 1
    5. showRange = 0
    6. showResultCount = 0
    7. hscText = 0
    8. }
    9.  
    10. #Labels
    11. plugin.tt_news._LOCAL_LANG.de {
    12. pi_list_browseresults_page = &nbsp;
    13. pi_list_browseresults_first = &lt;&lt;&nbsp;
    14. pi_list_browseresults_last = &nbsp;&gt;&gt;
    15. pi_list_browseresults_next = &gt;
    16. pi_list_browseresults_prev = &lt;
    17. }

    Ergibt bei mir folgende Ausgabe: << < 1 2 3 > >>

  • 1