23. 11. 2011, 19:21

Hi,
versuche gerade eine Domain bei 1&1 per SSL zu sichern.

Die original Seite ist unter http://www.meinedomain.de zu erreichen, die
SSL-Version unter https://www-ssl-id.de/meinedomain.de.

Im Installtool habe ich folgende Werte eingetragen:

  1. $TYPO3_CONF_VARS['SYS']['reverseProxyHeaderMultiValue'] = 'first';
  2. $TYPO3_CONF_VARS['SYS']['reverseProxyIP'] = '192.67.198.95'; //Proxy-IP
  3. $TYPO3_CONF_VARS['SYS']['reverseProxySSL'] = '192.67.198.95'; //Proxy-IP
  4. $TYPO3_CONF_VARS['SYS']['reverseProxyPrefix'] = '';
  5. $TYPO3_CONF_VARS['SYS']['reverseProxyPrefixSSL'] = '/meinedomain.de';

Da allerdings mod_rewrite und real_url verwendet werden scheint es noch notwendig zu sein, die .htaccess Datei anzupassen. Aktuell wird immer vom Apache Server immer nur "The requested URL / was not found on this server." angezeigt, wenn ich versuche die Startseite per https aufzurufen.

Hat damit vielleicht jemand Erfahrungen und kann mir helfen, die https-Verbindung korrekt zu konfigurieren?

CU
maxhb

Hier noch mal die .htaccess:

  1. RewriteEngine On
  2. RewriteBase /
  3. Options -Indexes
  4. AddType application/x-httpd-php3 .php3
  5. AddType application/x-httpd-php43 .php4
  6. AddType application/x-httpd-php5 .php .php5
  7.  
  8. RewriteRule ^typo3$ - [L]
  9. RewriteRule ^typo3/.*$ - [L]
  10. RewriteCond %{REQUEST_FILENAME} !-f
  11. RewriteCond %{REQUEST_FILENAME} !-d
  12. RewriteCond %{REQUEST_FILENAME} !-l
  13. RewriteRule .* index.php