awstats findet angeblich Perl nicht

  • Toking Toking
    Typ im Roten Hemd
    0 x
    2 Beiträge
    0 Hilfreiche Beiträge
    22. 04. 2004, 17:11

    Hallo zusammen,
    ich habe aw_stats installiert, das logfile unter /fileadmin/ angelegt,
    Schreibrechte im log-Verzeichnis von Apache eingerichtet. Alles soweit wunderbar.
    Wenn ich jetzt auf AWStats im Bereich Tool klicke und dann mein Logfile auswähle, dass ich bearbeiten will zeit er mir folgende Fehlermeldung:
    [code:1:fda46f4191]Perl was not found at '/usr/local/bin/perl'. The awstats.pl script can't be executed![/code:1:fda46f4191]

    Soweit so gut ich habe auch schon rausgefunden, dass mein Perl auf /usr/bin/perl zu finden ist.
    Die Fehlermeldung wird auch nicht vom Server generiert sondern stammt aus der index.php

    Auf der Kommandozeile läßt sich die awstats.pl aufrufen allerdings nicht über Typo3.
    Kann mir jemand weiterhelfen?

    Danke

    Tommy


  • 1
  • TW TW
    Jedi-General
    0 x
    1560 Beiträge
    0 Hilfreiche Beiträge
    23. 04. 2004, 10:11

    [quote:dda71972db="Toking"]Hallo zusammen,
    ich habe aw_stats installiert, das logfile unter /fileadmin/ angelegt,
    Schreibrechte im log-Verzeichnis von Apache eingerichtet. Alles soweit wunderbar.
    Wenn ich jetzt auf AWStats im Bereich Tool klicke und dann mein Logfile auswähle, dass ich bearbeiten will zeit er mir folgende Fehlermeldung:
    [code:1:dda71972db]Perl was not found at '/usr/local/bin/perl'. The awstats.pl script can't be executed![/code:1:dda71972db]

    Soweit so gut ich habe auch schon rausgefunden, dass mein Perl auf /usr/bin/perl zu finden ist.
    Die Fehlermeldung wird auch nicht vom Server generiert sondern stammt aus der index.php

    Auf der Kommandozeile läßt sich die awstats.pl aufrufen allerdings nicht über Typo3.
    Kann mir jemand weiterhelfen?

    Danke

    Tommy[/quote:dda71972db]

    hi
    hast du die suche schon probiert??
    wenn nicht dann geh mal hier hin, vielleicht hilft es ja weiter...

    http://www.typo3.net/viewtopic.php?t=9597&highlight=awstats
    http://www.typo3.net/viewtopic.php?t=9300&highlight=awstats

    cu
    thorsten

  • Toking Toking
    Typ im Roten Hemd
    0 x
    2 Beiträge
    0 Hilfreiche Beiträge
    23. 04. 2004, 11:38

    Ja auf den Threads bin ich mit der Suche auch schon gelandet, allerdings trefffen sie mein Problem nicht.
    Das System auf dem Typo3 läuft ist ein Suse Linux Server mit Apache.
    Der Apache ist für den Bereich auch so konfiguriert dass Skipts auch ausserhalb von cgi-bin laufen dürfen und wie gesagt auf der Kommandozeile via SSH läßt sich das awstats.pl auch ausführen nur eben nicht, wenn es aus der index.php aufgerufen wird.

    Vielleicht hat jemand einen guten Tip

    Gruß Toking

  • emanuel emanuel
    T3PO
    0 x
    9 Beiträge
    0 Hilfreiche Beiträge
    26. 05. 2004, 23:13

    Lösche folgende Zeilen in .../typo3conf/ext/cc_awstats/mod1/index.php

    [code:1:57cc4d70a9]
    if (is_executable ("/usr/bin/perl")) {
    $perl = "/usr/bin/perl ";
    } else {
    if (is_executable ("/usr/local/bin/perl")) {
    $perl = "/usr/local/bin/perl ";
    } else {
    die("Perl was not found at '/usr/local/bin/perl'. The awstats.pl script can't be executed!");
    }
    die("Perl was not found at '/usr/bin/perl'. The awstats.pl script can't be executed!");
    }
    [/code:1:57cc4d70a9]

    Lösche nicht die Zeile:

    [code:1:57cc4d70a9]
    $perl = "/usr/bin/perl ";
    [/code:1:57cc4d70a9]

    Ändere die Variable evtl. mit der richtigen Location des Perl-Programms.

    Dies ist ein Hack, funktioniert aber.

    Hoffe das hilft.

    Ray

  • lukas lukas
    Padawan
    0 x
    33 Beiträge
    0 Hilfreiche Beiträge
    16. 09. 2004, 17:13

    ich habe genau dasselbe problem und wollte nun den "hack" von emanuel ausprobieren - da ergibt sich bei mir jedoch ein ganz neues problem: ich kann das index.php-file nicht mehr uploaden, da ich darauf keine schreibberechtigung habe!!! besitzer des files ist "wwwrun" und ich kann weder umbenennen, chmod ändern noch löschen!
    kan mir da jemand helfen?

  • lukas lukas
    Padawan
    0 x
    33 Beiträge
    0 Hilfreiche Beiträge
    12. 10. 2004, 14:16

    konnte mein problem nun selber lösen und der "hack" funktioniert ausgezeichnet, danke emanuel (sollte man evtl. mal in einem update der extension berücksichtigen).

    nun für diejenigen, die ebenfalls extension-dateien auf dem server liegen haben und sie nicht editieren können: im extension manager einfach gewünschte ext anklicken und "edit files" auswählen.

  • Sukuma Sukuma
    Padawan
    0 x
    33 Beiträge
    0 Hilfreiche Beiträge
    21. 05. 2005, 21:46

    Hallo,
    danke, bei mir funktioniert es auch.
    Viele Grüsse Sukuma.

  • Merlin732 Merlin732
    R2-D2
    0 x
    120 Beiträge
    0 Hilfreiche Beiträge
    28. 09. 2005, 13:46

    Hallo,

    hatte das gleiche Problem, da der Pfad zu Perl ein anderer war.

    Danke für die Hilfe.

    MfG Lars

  • Heinrich Turnschuh Heinrich ...
    Typ im Roten Hemd
    0 x
    3 Beiträge
    0 Hilfreiche Beiträge
    23. 11. 2005, 13:49

    reicht es wenn man die Zeilen auskommentiert oder muss man sie wirklich löschen? Habe alles so gemacht, bei mir kommt dann aber:

    Warning: escapeshellcmd() has been disabled for security reasons in /var/www/html/web220/html/typo3conf/ext/cc_awstats/mod1/index.php on line 276

    Warning: passthru() has been disabled for security reasons in /var/www/html/web220/html/typo3conf/ext/cc_awstats/mod1/index.php on line 276

    als Ausgabe wenn ich auf logfile.txt clicke

  • molfi molfi
    Jedi-Ritter
    0 x
    103 Beiträge
    0 Hilfreiche Beiträge
    01. 02. 2006, 17:19

    danke. bei mir hat es so auch geklappt.

    zur info: man brauch die zeilen natürlich nicht löschen.
    auskommentieren mit // reicht auch.

    gruß
    molfi

  • 1