Eine Seite in TYPO3 über Subdomain bringt Meldung "Zugriff verweigert" [Gelöst]

  • Nowi Nowi
    Padawan
    0 x
    61 Beiträge
    0 Hilfreiche Beiträge
    23. 10. 2011, 23:22

    Mahlzeit!

    Habe mehrere Seiten in einer TYPO3 Installation laufen.
    Verschiedene Domains und Subdomains. Läuft alles prima. Jetzt habe ich erneut eine Subdomain im Confixx angelegt und der Seite im Seitenbaum auch den "Domäne" Eintrag entsprechend hinzugefügt. Wie ich es auch schon bei den anderen habe.
    Leider bekomme ich beim Aufruf der neuen Subdomain einen 403 Fehler. Zugriff verweigert.
    Die Subdomain zeigt natürlich auf das TYPO3 Verzeichnis.
    Wenn ich die Subdomain auf ein anderes Verzeichnis auf dem Server zeigen lasse, kann ich sie aufrufen und bekomme keinen Fehler. Serverseitig sollte also alles funktionieren.
    Ich habe realurl installiert. Kann es daran liegen? Dachte eigentlich nicht. Oder an der .htaccess?
    Hier mal der Inhalt meiner .htaccess

    1. #####
    2. #
    3. # Example .htaccess file
    4. #
    5. # This file contains a collection of almost everything you will need
    6. # for optimising TYPO3:
    7. #
    8. # - mod_rewrite (used for SimulateStaticDocuments, RealUrl, etc.)
    9. # - PHP optimisation
    10. #
    11. # If you want to use it, you'll need to rename this file to '.htaccess'.
    12. # (To make this work you will need to adjust the 'AllowOverride'
    13. # directive in your Apache configuration file.)
    14. #
    15. # IMPORTANT: You may need to change this file depending on your TYPO3
    16. # installation!
    17. #
    18. # You should change every occurance of TYPO3root/ to the location where you
    19. # have your website in. For example:
    20. # If you have your website located at http://mysite.com/
    21. # then your TYPO3root/ is just empty (remove 'TYPO3root/')
    22. # If you have your website located at http://mysite.com/some/path/
    23. # then your TYPO3root/ is some/path/ (search and replace)
    24. #
    25. # If you have problems with this file, try using the minimal
    26. # mod_rewrite.htaccess which is located in the typo3_src/misc/
    27. # directory of this installation.
    28. #
    29. # You can also use this configuration in your httpd.conf, but you'll have
    30. # to modify some lines, see the comments (search for 'httpd.conf')
    31. #
    32. # Using rewriting in your httpd.conf is much faster, btw.
    33. #
    34. # Questions about this file go to the matching Install mailing list,
    35. # see http://typo3.org/documentation/mailing-lists/
    36. #
    37. ####
    38.  
    39. ### Begin: Rewrite stuff ###
    40.  
    41. # Enable URL rewriting
    42. RewriteEngine On
    43.  
    44. # To assist in debugging rewriting, you could use these lines
    45. # DON'T enable it for production!
    46. # This will only work in httpd.conf, not in .htaccess files
    47. #RewriteLog /var/log/apache/rewrite.log
    48. #RewriteLogLevel 9
    49.  
    50. # If you use the RealUrl extension, then you'll have to enable the next line.
    51. # You will have to change this path if your TYPO3 installation is located
    52. # in a subdirectory of the website root.
    53. #
    54. # If you place this in httpd.conf, you cannot use this directive in any case!
    55. #RewriteBase /
    56.  
    57. # Stop rewrite processing if we are in the typo3/ directory
    58. # For httpd.conf, use this line instead of the next one:
    59. # RewriteRule ^/TYPO3root/(typo3|t3lib|tslib|fileadmin|typo3conf|typo3temp|uploads|showpic\.php|favicon\.ico)/ - [L]
    60.  
    61. RewriteRule ^(typo3|t3lib|tslib|fileadmin|typo3conf|typo3temp|uploads|showpic\.php|favicon\.ico)/ - [L]
    62.  
    63. # Redirect http://mysite/typo3 to http://mysite/typo3/index_re.php
    64. # and stop the rewrite processing
    65. # For httpd.conf, use this line instead of the next one:
    66. # RewriteRule ^/TYPO3root/typo3$ /TYPO3root/typo3/index.php [L]
    67.  
    68. RewriteRule ^typo3$ typo3/index_re.php [L]
    69.  
    70. # If the file/symlink/directory does not exist => Redirect to index.php
    71. # Important note: If you copy/paste this into httpd.conf instead
    72. # of .htaccess you will need to add '%{DOCUMENT_ROOT}' left to each
    73. # '%{REQUEST_FILENAME}' part.
    74.  
    75. RewriteCond %{REQUEST_FILENAME} !-f
    76. RewriteCond %{REQUEST_FILENAME} !-d
    77. RewriteCond %{REQUEST_FILENAME} !-l
    78.  
    79. # Main URL rewriting.
    80.  
    81. # If you use Windows and SimulateStaticDocuments do not work, try adding a
    82. # slash (/) right before 'index.php' below.
    83.  
    84. # The example shows how to rewrite only *.html and *.pdf files to index.php
    85. # This may be helpful when using an extension that can generate PDF files
    86. # on the fly.
    87. # Example: RewriteRule .*\.(html|pdf)$ index.php [L]
    88.  
    89. # For httpd.conf, use this line instead of the next one that has no '#':
    90. # RewriteRule .* /TYPO3root/index.php [L]
    91.  
    92. # For use with the RealUrl extension, you might need to remove the
    93. # RewriteBase directive somewhere above and use this line instead of the
    94. # next one:
    95. # RewriteRule .* /index.php [L]
    96.  
    97. RewriteRule .* index.php [L]
    98.  
    99. ### End: Rewrite stuff ###
    100.  
    101. ### Begin: PHP optimisation ###
    102.  
    103. # All features below are left to the default if you don't change this.
    104. # Simply remove the comment marks if you want to use some/all of these
    105. # settings
    106.  
    107. # The PHP developers recommend disabling this feature. Do that.
    108. # It's deprecated and is likely to be unsupported in future versions of PHP.
    109. #php_flag allow_call_time_pass_reference off
    110.  
    111. # TYPO3 works fine with register_globals turned off.
    112. # This is highly recommended!
    113. #php_flag register_globals off
    114.  
    115. # PHP may not declare the argv & argc variables (that would contain the GET
    116. # information).
    117. # TYPO3 doesn't need this, so just turn it off.
    118. #php_flag register_argc_argv off
    119.  
    120. # Magic quotes for runtime-generated data (data from SQL, exec(), etc.)
    121. #php_flag magic_quotes_gpc off
    122.  
    123. # Order in which PHP registers GET, POST, Cookie and Built-in variables
    124. #php_value variables_order GPCS
    125.  
    126. ### End: PHP optimisation ###
    127.  
    128. ### Begin: Miscellaneous ###
    129.  
    130. # Make sure that directory listings are disabled
    131. #Options -Indexes
    132.  
    133. # There is a problem with Internet Explorer and mod_gzip on Apache servers.
    134. # For more information, see
    135. # http://typo3.org/documentation/document-library/rtehtmlarea/Tutorial-79/
    136. #mod_gzip_item_exclude file \.css$
    137. #mod_gzip_item_exclude file \.png$
    138. #mod_gzip_item_exclude file \.gif$
    139. #mod_gzip_item_exclude file \.jpg$
    140. #mod_gzip_item_exclude file \.jpeg$
    141. #mod_gzip_item_exclude file \.js$
    142.  
    143. ### End: Miscellaneous ###
    144.  
    145. # Add your own rules here
    146. # ...
    147. RewriteBase /
    148. RewriteRule ^[^/]*\.html$ index.php

    Jemand eine Idee woran es liegen kann?


  • 1
  • Nowi Nowi
    Padawan
    0 x
    61 Beiträge
    0 Hilfreiche Beiträge
    24. 10. 2011, 22:13

    Mahlzeit!

    Problem gelöst.
    mod_rewrite war für die neue Subdomain nicht aktiv. Nur für alle anderen (älteren) Domains bzw. Subdomains.
    Dachte eigentlich, dass das für neu angelegte Domains bzw. Subdomains aktiv ist. War aber anscheinend doch nicht.

  • 1