t3lib_error_Exception nach upgrade [Gelöst]

  • chrickenh chrickenh
    Jedi-Ritter
    0 x
    140 Beiträge
    0 Hilfreiche Beiträge
    22. 09. 2011, 13:39

    Hi,

    ich habe mein Typo3 von einer alten Version auf 4.4.4 upgedatet.
    Das hat mehrere Wochen lang funktioniert und jetzt nicht mehr.

    Die Meldung, die ich im FE bekomme lautet:

    1. t3lib_error_Exception
    2.  
    3. PHP : Function ereg() is deprecated in /home/www/chricken.de/typo3conf/ext/templavoila/class.tx_templavoila_htmlmarkup.php line 523

    Ich habe schon alle Extension deinstalliert, die für den Betrieb nicht unbedingt benötigt sind. Wüsste nicht, was ich geändert hätte, bevor der Fehler auftauchte.
    Was ich bis jetzt rausgefunden habe ist, dass ereg veraltet ist und in neuen Versionen von php nicht mehr unterstützt wird (ich nutze PHP 5.3.2). Ich will es aber eigentlich vermeiden, im Quellcode zu hantieren.

    Kann mir jemand helfen?
    Danke
    Chricken


  • 1
  • maxhb maxhb
    Flash Gordon
    0 x
    2148 Beiträge
    0 Hilfreiche Beiträge
    23. 09. 2011, 17:33

    Der Fehler deutet klar auf ein Problem in Templa Voila hin, aktualisiere doch mal diese Extension, mittlerweile dürfte die hoffentlich mit PHP 5.3 kompatibel sein.

    Alternativ kannst Du im Install-Toll einstellen, dass "deprecation warnings" nicht mehr angezeigt werden sollen. Die entsprechenden Möglichkeiten findest Du im Abschnitt "All configuration" unter den Punkten [displayErrors], [errorHandlerErrors]und [exceptionalErrors].

    CU
    maxhb

  • chrickenh chrickenh
    Jedi-Ritter
    0 x
    140 Beiträge
    0 Hilfreiche Beiträge
    23. 09. 2011, 18:43

    Das war's, ich werde auch gleich die anderen Extensions aktualisieren.
    Heißen Dank :)

  • maxhb maxhb
    Flash Gordon
    0 x
    2148 Beiträge
    0 Hilfreiche Beiträge
    23. 09. 2011, 19:28

    Ist doch schön, wenn die Lösung mal so einfach ist :)

  • 1