gmenu -> problem mit kerning.

  • luko luko
    T3PO
    0 x
    26 Beiträge
    0 Hilfreiche Beiträge
    15. 09. 2011, 14:07

    hallo,

    habe ein problem mit einem grafischen menü:

    auf dem lokalen entwicklungsserver sehen alle buttons wunderbar aus, auf dem live-system bei dF ist das kerning miserabel (siehe beispielbild)

    [img]http://www.freeimagehosting.net/5324e[/img]

    lokal: ImageMagick-6.6.7-2
    dF : ImageMagick-6.6.2-5

    alle einstellungen identisch. auch mit verschiedenen anderen einstellungen getestet. auch mit anderen fonts getestet. sieht alles bescheiden aus.

    liegt es an der IM version? oder wo kann ich bei der fehlersuche ansetzen? hat wer eine idee?

    gruß, carsten


  • 1
  • fuss fuss
    Jedi-Meister
    0 x
    375 Beiträge
    0 Hilfreiche Beiträge
    15. 09. 2011, 21:09

    Olla!

    Sofern auf dem Live-System PHP 5.3.2 installiert ist, könnte es daran liegen, da diese Version einen kerning bug haben soll.

    In 5.3.3 soll der bug behoben sein.

    Quelle:
    [url=http://bugs.php.net/bug.php?id=51207]https://bugs.php.net/bug.php?id=51207[/url]

    via:
    [url=http://old.nabble.com/gifbuilder-text-rendering-issue-td29236241.html]http://old.nabble.com/gifbuilder-text-rendering-issue-td29236241.html[/url]

    [edit]@admin: Der Linkparser scheint https Links nicht korrekt darzustellen
    [/edit]

    gruss, fuss

    my system:
    C-64 I, 65816@20mhz, 16mb ram, 4x 6581r4 (12 channel fm-sound), 384mb scsi hd
    go sixtyfour! go!

  • luko luko
    T3PO
    0 x
    26 Beiträge
    0 Hilfreiche Beiträge
    15. 09. 2011, 21:50

    ja da soll man erstmal drauf kommen...

    php lokal: 5.2.8
    php live: 5.2.13

    php live auf 5.2.17 umgestellt - jetzt geht's

    vielen dank!!!

  • fuss fuss
    Jedi-Meister
    0 x
    375 Beiträge
    0 Hilfreiche Beiträge
    15. 09. 2011, 22:36

    > php lokal: 5.2.8
    > php live: 5.2.13

    ah, ok. Anscheinend ist der bug auch in einigen 5.2. Versionen vorhanden.
    Gut zu wissen :)

    gruss, fuss

    my system:
    C-64 I, 65816@20mhz, 16mb ram, 4x 6581r4 (12 channel fm-sound), 384mb scsi hd
    go sixtyfour! go!

  • 1