fl_realurl_image virtualPathRemove

  • Knalltuete Knalltuet...
    Sternenflotten-Admiral
    0 x
    169 Beiträge
    0 Hilfreiche Beiträge
    05. 05. 2011, 10:47

    Ich habe die Version 2.0.6 im Einsatz und wie im Manual beschrieben folgenden Code in meine .htaccess eingepflegt.

    1. RewriteCond %{REQUEST_URI} !^/(fileadmin|typo3temp) [NC]
    2. RewriteCond %{REQUEST_URI} !^/typo3temp/fl_realurl_image [NC]
    3. RewriteCond %{REQUEST_URI} ^/[^/]+\.(gif|png|jpg|jpeg) [NC]
    4. RewriteRule (.+) /typo3temp/fl_realurl_image/$1 [L,NC,E=FLREALURL_REDIRECT:1]
    5.  
    6. # produce a 403 "forbiddden" for fl_realurl_image protection
    7.  
    8. RewriteRule ^(typo3temp|uploads)/.*\.(jpg|png|gif)$ - [F]
    9.  
    10. # produce a 404 "not found"
    11.  
    12. #RewriteRule ^(typo3temp|uploads)/.*\.(jpg|png|gif)$ not-found [L]
    13.  
    14. # produce a 410 "gone"
    15.  
    16. #RewriteRule ^(typo3temp|uploads)/.*\.(jpg|png|gif)$ - [G]

    In den Extension Einstellungen habe ich virtualPathRemove auf typo3temp/fl_realurl_image/ gesetzt.

    Der Pfad wird im Quelltext der Seite verkürzt, allerdings werden keine Bilder mehr angezeigt. Hat jemand eine Idee woran es liegen kann? Ich nutze ein LAMP System.


  • 1
  • flashsilver flashsilv...
    Sternenflotten-Admiral
    0 x
    214 Beiträge
    0 Hilfreiche Beiträge
    22. 06. 2011, 10:30

    Hallo,

    ich habe die 2.0.9 im Einsatz mit der aktuellsten realurl. Ich bekomme die verkürzte Version auch nicht zum laufen. Die Rules scheinen in Ordnung zu sein, aber sicher bin ich da nicht.

    Hast Du mittlerweile eine Lösung finden können?

    gruß
    flashsilver

  • Knalltuete Knalltuet...
    Sternenflotten-Admiral
    0 x
    169 Beiträge
    0 Hilfreiche Beiträge
    14. 07. 2011, 09:29

    nein leider nicht..

  • kkraft82 kkraft82
    T3PO
    0 x
    10 Beiträge
    0 Hilfreiche Beiträge
    16. 05. 2012, 23:22

    Hallo,

    gleiches Problem bei mir. Hat einer von euch mittlerweile eine Lösung oder hat jemand anders eine?

    Danke und Grüße Kristian

  • George Mason George Ma...
    Sternenflotten-Admiral
    0 x
    157 Beiträge
    0 Hilfreiche Beiträge
    24. 01. 2013, 13:29

    gleiches Problem mit Version 2.1.11. Ich habe für das Projekt auch keinen Bugtracker oder Eintrag bei TYPO3 Forge gefunden.

    Update auf 2.1.12 - gleiches Problem. Keine Ahnung, ob nur die Doku verkehrt ist oder ob die verkürzte Funktion tatsächlich nicht funktioniert.

  • 1