Ausgabe von ###NEWS_IMAGE### [Gelöst]

  • MajPay MajPay
    Jedi-Meister
    0 x
    345 Beiträge
    2 Hilfreiche Beiträge
    28. 04. 2011, 13:52

    Hi

    Der Marker ###NEWS_IMAGE### gibt mir in der Single Ansicht einen fertigen HTML Code aus, ich möchte diesen aber anders haben, und zwar so:

    1. <p class="tagline">
    2. <em>eine supertolle, zum Bild passende Bildunterschrift.</em>
    3. </p>
    4. <a href=".../news-1-big.jpg" class="imageZoom"><img src=".../news-1.jpg" alt="image"/></a>

    Wo kann ich das denn anpassen?
    Von tt_news bekomme ich sowas:
    1. <a href="index.php?eID=tx_cms_showpic&amp;file=uploads%2Fpics%2Fnews-1-big.jpg&amp;md5=2215a412a356b73b3f34c5e286961bc351ee8851&amp;parameters[0]=YTo0OntzOjU6IndpZHRoIjtzOjQ6IjgwMG0iO3M6NjoiaGVpZ2h0IjtzOjM6IjYw&amp;parameters[1]=MCI7czo3OiJib2R5VGFnIjtzOjQyOiI8Ym9keSBiZ0NvbG9yPSIjZmZmZmZmIiBz&amp;parameters[2]=dHlsZT0ibWFyZ2luOjA7Ij4iO3M6NDoid3JhcCI7czozNzoiPGEgaHJlZj0iamF2&amp;parameters[3]=YXNjcmlwdDpjbG9zZSgpOyI%2BIHwgPC9hPiI7fQ%3D%3D" onclick="openPic('index.php?eID=tx_cms_showpic&amp;file=uploads%2Fpics%2Fnews-1-big.jpg&amp;md5=2215a412a356b73b3f34c5e286961bc351ee8851&amp;parameters[0]=YTo0OntzOjU6IndpZHRoIjtzOjQ6IjgwMG0iO3M6NjoiaGVpZ2h0IjtzOjM6IjYw&amp;parameters[1]=MCI7czo3OiJib2R5VGFnIjtzOjQyOiI8Ym9keSBiZ0NvbG9yPSIjZmZmZmZmIiBz&amp;parameters[2]=dHlsZT0ibWFyZ2luOjA7Ij4iO3M6NDoid3JhcCI7czozNzoiPGEgaHJlZj0iamF2&amp;parameters[3]=YXNjcmlwdDpjbG9zZSgpOyI%2BIHwgPC9hPiI7fQ%3D%3D','9e603caf7202e6cd003e1b23d6b4c198','width=540,height=360,status=0,menubar=0'); return false;" target=""><img src="typo3temp/pics/7e366a8d24.jpg" width="180" height="120" alt="" /></a><p class="news-single-imgcaption" style="width:180px;">eine supertolle, zum Bild passende Bildunterschrift</p>


  • 1
  • MajPay MajPay
    Jedi-Meister
    0 x
    345 Beiträge
    2 Hilfreiche Beiträge
    28. 04. 2011, 16:48

    Okay, bin nun soweit, dass ich weiß, dass die onclick scheiße von tt_content kommt (oder doch nicht?)

    Folgende TS bringen aber nichts:

    1. tt_content.image.20.1.imageLinkWrap >
    2. page.config.setJS_openPic >
    3. tt_content.image.20.1.imageLinkWrap = 0
    4. page.config.setJS_openPic = 0

    Ich möchte diesen Unsinn bei allen Bildern entfernen, hat jemand eine Extension oder eine Idee?

    Edit:

    Hier habe ich die Lösung gefunden (Danke an dieser Stelle):
    http://www.marcoseiler.de/typo3/typo3-inhalte-ausgeben/typo3-lightbox-ohne-extension.html

    Und falls der Link stirbt hier das TS:

    1. tt_content.image.20.1.imageLinkWrap {
    2. JSwindow = 0
    3. directImageLink = 1
    4. linkParams.ATagParams {
    5. dataWrap = class="imageZoom"
    6. }
    7. }
    8.  
    9. tt_news {
    10. displaySingle.image.imageLinkWrap {
    11. JSwindow = 0
    12. directImageLink = 1
    13. linkParams.ATagParams = class="imageZoom"
    14. height =
    15. width =
    16. }
    17. }
    18. }

  • 1