Typo Problem

  • nomis2010 nomis2010
    R2-D2
    0 x
    64 Beiträge
    0 Hilfreiche Beiträge
    07. 01. 2011, 10:36

    Hallo Zusammen,

    Ich hab eine Fehlermeldung, mit der ich nichts anfangen kann,die Seite, welche ich mit hilfe von Typo erstellt hatte, wird nicht mehr angezeigt.

    Wenn ich auf die Seite gehen will, kommt folgende Fehlermeldung:

    Warning: require_once() [function.require-once]: SAFE MODE Restriction in effect. The script whose uid is 10016 is not allowed to access /var/www/vhosts/XXXXXXXXXXXXXXX.de/httpdocs/typo/typo3conf/ext/rgsmoothgallery/class.tx_rgsmoothgallery_fe.php owned by uid 33 in /var/www/vhosts/XXXXXXXXXXXXXXX.de/httpdocs/typo/typo3conf/temp_CACHED_FE_psac31_ext_localconf.php on line 1001

    Warning: require_once(/var/www/vhosts/XXXXXXXXXXXXXXX.de/httpdocs/typo/typo3conf/ext/rgsmoothgallery/class.tx_rgsmoothgallery_fe.php) [function.require-once]: failed to open stream: No such file or directory in /var/www/vhosts/XXXXXXXXXXXXXXX.de/httpdocs/typo/typo3conf/temp_CACHED_FE_psac31_ext_localconf.php on line 1001

    Fatal error: require_once() [function.require]: Failed opening required '/var/www/vhosts/XXXXXXXXXXXXXXX.de/httpdocs/typo/typo3conf/ext/rgsmoothgallery/class.tx_rgsmoothgallery_fe.php' (include_path='.:') in /var/www/vhosts/XXXXXXXXXXXXXXX.de/httpdocs/typo/typo3conf/temp_CACHED_FE_psac31_ext_localconf.php on line 1001

    kann mir jemand helfen?

    vielen dank im vorus!!!

    Gruß
    Nomis


  • 1
  • lisardo lisardo
    Jedi-Meister
    0 x
    306 Beiträge
    0 Hilfreiche Beiträge
    07. 01. 2011, 11:52

    Hallo,

    du hast rgsmoothgallery installiert, vermutlich über den Extensions Manager. Leider ist dein Server fehlerhaft konfiguriert, so dass diese Dateien jetzt andere User/Rechte haben als der Rest der PHP-Dateien von TYPO3. Dadurch greift der in der php.ini eingestellte SAFE MODE, der genau das verbietet, und verhindert die Ausführung der PHP-Dateien von rgsmoothgallery.

    Abhilfe:
    - SAFE MODE ausschalten (lassen)
    - oder SAFE MODE korrekt konfigurieren lassen (z. B. nicht auf Dateirechte sondern auf Gruppenrechte, was möglich ist)
    - oder die Berechtigungen der Dateien korrigieren. Das wirst du in dem Fall immer machen müssen, wenn du eine Extension installierst. Falls das per FTP überhaupt möglich ist.

    Gruß
    Peter, [url=http://www.typo3-lisardo.de]TYPO3 @ lisardo (Augsburg)[/url]

  • 1