Bezahlung per Paypal wird nicht beendet

  • AlexD AlexD
    T3PO
    0 x
    8 Beiträge
    0 Hilfreiche Beiträge
    17. 12. 2010, 15:49

    Hallo,

    Ich verwende tt_products (2.6.0) für ein Shopsystem in Typo3 (4.2.12).

    Der Ablauf funktioniert soweit:

    - Produkt in Warenkorb legen
    - Käuferdaten eintragen
    - Paypal als Bezahlung wählen
    - Bestellung absenden -> weiterleitung auf Paypal-Seite
    - Preis aus Warenkorb wird richtig an Paypal gesendet
    - Bezahlvorgang bei Paypal absenden -> weiterleitung zurück zum Shop

    Beim letzten Punkt tritt allerdings dann schon ein Problem auf. Man landet nachdem man von Paypal weitergeleitet wird nicht auf der Bestellabschluss-Seite, sondern wieder im Warenkorb mit dem ausgewählten Produkt.
    Zudem wird bei Paypal unter "letzte Aktivitäten" (und auch sonst nirgends) die Aktivität verzeichnet.
    Somit vermute ich, dass der Bestellvorgang gar nicht richtig abgeschlossen wird und Paypal kein letztes "Go" vom Shop bekommt.
    Es erfolgt natürlich auch keine Verrechnung, Abbuchung oder ähnliches genauso wie keine Bestätigungsmails versendet werden.

    Das Seltsame an der Geschichte ist, dass in der letzten Zeit nichts an diesem Shop geändert wurde, außer neue Produkte ein zu stellen. Bedeutet Typoscript und Templates sind seit Wochen wenn nicht gar Monaten unangetastet.

    Leider konnte ich auch keine Informationen über eine API-Änderung bei PayPal finden.

    Jemand eine Idee woran es liegen könnte?


  • 1
  • typotom typotom
    T3PO
    0 x
    12 Beiträge
    0 Hilfreiche Beiträge
    04. 02. 2011, 15:26

    Hi AlexD,

    ich leide unter den selben Problemen. Nach Paypal komme ich wieder im Warenkorb raus und die Bestellung ist nicht abgeschlossen.

    Konntest Du das Problem schon lösen?

    WÄre echt klasse wenn Du berichten könntest.

    viele Grüße

    Tom

  • AlexD AlexD
    T3PO
    0 x
    8 Beiträge
    0 Hilfreiche Beiträge
    06. 02. 2011, 15:18

    Konnte das Problem bisher leider auch noch nicht lösen.

    Bin immernoch am Herausfinden woran es liegt. Wenn ich was finde melde ich mich aber noch mal :)

  • typotom typotom
    T3PO
    0 x
    12 Beiträge
    0 Hilfreiche Beiträge
    06. 02. 2011, 18:44

    So ich habs.

    Du Musst als Return Url wieder zurück auf den Warenkorb.
    In Paypal die automatische Rückleitung aktivieren, das Authtoken hinterlegen, und schon gehts.

    Allerdings wird bei mir nix von wegen Zahlungsabwicklung in dem paymentlib sysfolder hinterlegt...
    Egal, das Paypal ding geht. Zwar ohne IPN aber dafür aus der Extension heraus :)

    Grüße

  • chollatz chollatz
    T3PO
    0 x
    9 Beiträge
    0 Hilfreiche Beiträge
    26. 05. 2011, 18:01

    Hallo Ihr beiden,

    habt Ihr dafür vielleicht einmal ein Code Schnipsel wie ihr das eingebaut habt im Template, sitze da gerade auch dran und so richtig fluppt das noch nicht wie ich es will.

    LG

  • 1