doNotLinkIt = 1 hat keine Wirkung [Gelöst]

  • eisstern eisstern
    R2-D2
    0 x
    112 Beiträge
    0 Hilfreiche Beiträge
    05. 11. 2010, 10:00

    Hallo,
    ich habe ein Sprachmenu gebaut, welches mir Flaggen anzeigt. Ist eine Seite in einer Sprache nicht verfügbar, soll einfach der Link auf der Flagge entfernt werden, das Bild aber bleiben.

    In der jetzigen Konfiguration sind bei den Seiten die es betrifft überall "hide default translation" gesetzt. Also keine Defaultsprache verfügbar. Das Menü berücksichtigt dies schon bei der Ausgabe, da der allWrap aus USERDEF1 verwendet wird. Allerdings wird die Flagge immernoch verlinkt. Die Frage ist warum? Ich bekomme den Link einfach nicht entfernt.

    1. lib.flags = HMENU
    2. lib.flags {
    3. special = language
    4. special.value = 0,1,2
    5. special.normalWhenNoLanguage = 0
    6. 1 = TMENU
    7. 1 {
    8. noBlur = 1
    9. NO = 1
    10. NO {
    11. stdWrap.override = <img src="fileadmin/templates/img/flaggen/de.gif" alt="Deutsch" /> || <img src="fileadmin/templates/img/flaggen/en.gif" alt="English" /> || <img src="fileadmin/templates/img/flaggen/fr.gif" alt="Francaise" />
    12. stdWrap.typolink.parameter.data = page:uid
    13. stdWrap.typolink.additionalParams = &L=0 || &L=1 || &L=2
    14. stdWrap.typolink.addQueryString = 1
    15. stdWrap.typolink.addQueryString.exclude = L,id,cHash,no_cache
    16. stdWrap.typolink.addQueryString.method = GET
    17. stdWrap.typolink.useCacheHash = 0
    18. stdWrap.typolink.no_cache = 0
    19. }
    20.  
    21. doNotLinkIt = 1
    22. allWrap = blub|
    23. }
    24. }
    25. }


  • 1
  • eisstern eisstern
    R2-D2
    0 x
    112 Beiträge
    0 Hilfreiche Beiträge
    05. 11. 2010, 11:13

    Die besten Lösungsideen kommen immer kurz nachdem man die Frage gestellt hat.

    Man verwendet beim Menu ja nicht den normalen Typolink, sondern den stdWrap um diesen zu erzeugen. Also muss man einfach den stdWrap in USERDEF1 löschen.

    Alles gleich bis auf USERDERF1

    1. }

  • 1