_pi1 wird nicht geladen und vollständig ignoriert

  • extension22 extension...
    Sternenflotten-Admiral
    0 x
    208 Beiträge
    0 Hilfreiche Beiträge
    16. 09. 2010, 10:26

    Hallo,

    konkret Extension file_list.

    Funktioniert problemlos bei einigen 4.4 Installationen.
    Aber auf einer wird die _pi1-Datei nicht includiert. Ich kann da einen Syntax-Fehler oder die() einbauen und habe keinen Effekt.
    ext_localconf.php und ext_tables.php werden geladen.
    Andere Plugins in der Installation funktionieren auch.
    Auf einer anderen Installation auf demselben Server mit demselben verlinken typo3_src und derselben php-Version (5.2.12) funktioniert es.
    Das riecht etwas nach Berechtigungsproblemen, finde aber keine Anhaltspunkte dafür.

    Weiß jemand, wo ich debuggen kann, wenn die _pi1 komplett ignoriert wird?

    Danke!


  • 1
  • karlchen karlchen
    Jedi-General
    0 x
    1433 Beiträge
    30 Hilfreiche Beiträge
    16. 09. 2010, 14:24

    hmm, deine localconf.php kann nicht beschrieben werden und damit wurde die Extension gar nicht installiert ?

  • extension22 extension...
    Sternenflotten-Admiral
    0 x
    208 Beiträge
    0 Hilfreiche Beiträge
    16. 09. 2010, 14:29

    [quote="karlchen"]
    hmm, deine localconf.php kann nicht beschrieben werden und damit wurde die Extension gar nicht installiert ?
    [/quote]
    Danke!

    So in der Art sieht es am Anfang auch aus.
    Aber doch, leider schon. localconf.php ist beschreibbar und die Ext. ist installiert, ext_localconf.php und ext_tables.php werden ja geladen, aber die _pi1 nicht.
    Es liegt sicher irgendwo lokal in der Installation. Ein Kollege hat die jetzt lokal gezogen (das Problem ist reproduzierbar) und sucht seit 3 Stunden mit Xdebug.

  • karlchen karlchen
    Jedi-General
    0 x
    1433 Beiträge
    30 Hilfreiche Beiträge
    16. 09. 2010, 14:37

    die pi's werden für gewöhnlich in der ext_localconf.php
    mit folgendem (ähnlichem) PHP Schnipsel geladen

    1. t3lib_extMgm::addPItoST43($_EXTKEY, 'pi1/class.tx_filelist_pi1.php', '_pi1', 'list_type', $settings['noCache'] ? 0 : 1);

    Vielleicht könnt ihr da erstmal ansetzen.

    welche Extension habt ihr denn genau ?
    im Ter gibt es eine Extension mit Extension key "file_list" und eine mit Namen "file_list"

  • extension22 extension...
    Sternenflotten-Admiral
    0 x
    208 Beiträge
    0 Hilfreiche Beiträge
    16. 09. 2010, 14:55

    [quote="karlchen"]
    die pi's werden für gewöhnlich in der ext_localconf.php
    mit folgendem (ähnlichem) PHP Schnipsel geladen

    1. t3lib_extMgm::addPItoST43($_EXTKEY, 'pi1/class.tx_filelist_pi1.php', '_pi1', 'list_type', $settings['noCache'] ? 0 : 1);

    Vielleicht könnt ihr da erstmal ansetzen.

    welche Extension habt ihr denn genau ?
    im Ter gibt es eine Extension mit Extension key "file_list" und eine mit Namen "file_list"
    [/quote]

    Danke!
    Wir haben file_list
    Genau, das ist auch alles drin.
    Wir haben auch schon eine ext_autoloader.php im ext.Verzeichnis angelegt. Die wurde leider auch ignoriert.
    Grüße,
    Ext.22

  • extension22 extension...
    Sternenflotten-Admiral
    0 x
    208 Beiträge
    0 Hilfreiche Beiträge
    17. 09. 2010, 11:42

    Wir haben die Site jetzt in eine jungfräuliche Installation übertragen. (Hätte mich schon interessiert, was die Ursache war)

  • 1