defaultSprache immer als Kürzel an URL hängen [Gelöst]

  • karlchen karlchen
    Jedi-General
    0 x
    1433 Beiträge
    30 Hilfreiche Beiträge
    16. 07. 2010, 21:02

    hallo irgendwie stehe ich gerade auf dem Schlauch,

    ich habe eine mehrsprachige Website und um Double Content zu verhindern soll immer beim Aufruf der Seite ein Sprachkürzel angehängt werden. Mit der rlmp_language_detection klappt es bei allen anderen Sprachen ausser der DefaultSprache.
    Ich würde somit gerne einstellen, das auf der Startseite immer domain.com/de/ statt domain.com/ aufgerufen wird.

    Gibt es dafür eine Einstellung ?


  • 1
  • 0 x
    3270 Beiträge
    157 Hilfreiche Beiträge
    19. 07. 2010, 11:56

    Hallo.

    Da Du anscheinend realURl im Einsatz hast, dürfte Dich die Konfiguartion mit valueDefault weiterbringen. Einfach mal in der realURL-Doku danach suchen. Gibt gleich ein Beispiel mit Sprachen/L-Parameter dazu.

    Viele Grüße
    Julian

    Kleiner Hinweis:
    das Forum hier ist leider nicht mehr so frequentiert :-(
    Für schnellere Hilfe und mehr Leser, guck mal
    - auf stackoverflow ( https://stackoverflow.com/questions/tagged/typo3 )
    - oder in die slack-Channels ( https://typo3.org/community/meet/chat-slack )

  • karlchen karlchen
    Jedi-General
    0 x
    1433 Beiträge
    30 Hilfreiche Beiträge
    20. 07. 2010, 17:39

    hallo Julian,

    valueDefault habe ich ebenfalls ausprobriert und wenn ich nichts übersehen haben sollte, wird dieser Wert für alle "weiterführenden Links" genutzt.
    Wenn ich also auf der Startseite bin, werden alle Links des Menus direkt mit meinem valueDefault versehen, jedoch wird direkt die Startseite/Einstiegsseite nicht mit dem valueDefault versehen.

    Wenn ich meine Seite aufrufe mit domain.com, soll direkt zu domain.com/de/ weitergeleitet werden.

  • 0 x
    3270 Beiträge
    157 Hilfreiche Beiträge
    20. 07. 2010, 19:54

    Da wäre dann eine ergänzende Rewrite-Regel nötig

    1. RewriteCond %{REQUEST_URI} ^/(nc/)?(de|en|it)
    2. RewriteRule (.*) http://www.example.com/de%{REQUEST_URI} [R=301,L]

    Kleiner Hinweis:
    das Forum hier ist leider nicht mehr so frequentiert :-(
    Für schnellere Hilfe und mehr Leser, guck mal
    - auf stackoverflow ( https://stackoverflow.com/questions/tagged/typo3 )
    - oder in die slack-Channels ( https://typo3.org/community/meet/chat-slack )

  • karlchen karlchen
    Jedi-General
    0 x
    1433 Beiträge
    30 Hilfreiche Beiträge
    21. 07. 2010, 13:30

    danke Julian, ich werde es damit mal probieren.

    Eine TYPO3 eigene Lösung würde ich allerdings schöner finden :)

  • jonas8 jonas8
    Sternenflotten-Admiral
    0 x
    243 Beiträge
    0 Hilfreiche Beiträge
    30. 11. 2010, 15:04

    Hallo karlchen

    Hast Du eine Lösung gefunden?

    Probiere dies nun auch schon eine ganze Weile mit der rlmp_language_detection.

    Aber es will einfach nicht. Wie hast Du es gelöst?

    Danke und Gruss
    Jonas

  • jonas8 jonas8
    Sternenflotten-Admiral
    0 x
    243 Beiträge
    0 Hilfreiche Beiträge
    01. 12. 2010, 11:28

    Hallo Julian.Hofmann

    Auch mit deinem Vorschlag mit der Rewrite-Regel funktioniert es bei mir nicht.

    Habe in die .htaccess-Datei folgendes eingetragen:

    1. RewriteCond %{REQUEST_URI} ^/(nc/)?(de|en|fr)
    2. RewriteRule (.*) http://t3update.serv-ch.ch/de%{REQUEST_URI} [R=301,L]

    Aber leider ohne Wirkung. Was muss noch beachtet werden?

    Danke und Gruss
    Jonas

  • jonas8 jonas8
    Sternenflotten-Admiral
    0 x
    243 Beiträge
    0 Hilfreiche Beiträge
    01. 12. 2010, 16:12

    Ich habe es jetzt gefunden!

    rlmp_language_detection Version 2.0.4

    In der [b]class.tx_rlmplanguagedetection_pi1.php[/b]
    in der Zeile 231 steht:

    1. if(!$this->conf['dieAtEnd'] && $preferredLanguageOrPageUid != 0) {

    && $preferredLanguageOrPageUid != 0 [b]löschen[/b]

    [b]Also neu nur noch:[/b]

    1. if(!$this->conf['dieAtEnd']) {

    Ich werde versuchen den Entwickler zu kontaktieren,
    eventuell kann man ja das als Option einbauen.

    Have Fun!
    Jonas

  • 1