mm-forum: weiße seite für nicht-admins

  • olibert olibert
    Jedi-Ritter
    0 x
    134 Beiträge
    0 Hilfreiche Beiträge
    05. 10. 2009, 23:43

    schockschwerenot, habe soeben bemerkt, dass in einem forum (0.1.7) alles prima aussieht, solange man nicht eingeloggt ist. zur gruppe admins gehörende benutzer sehen auch alles, wie es sein soll - loggt sich hingegen ein normaler user ein, um einen beitrag verfassen zu können, bekommt dieser nach erfolgtem login und klick auf einen forums-eintrag eine leere seite (und ich meine leer - kein stück quelltext zu entdecken, page not found) angezeigt.
    es spielt dabei übrigens keine rolle, ob und welche gruppe ich dem forum mit welchen rechten mitgebe - nach dem login als nichtadmin = ende forum :-(

    woran mag das liegen - hiilfe - erbitte dringend nen denkanstoß.

    danke und gruss
    olibert

    (ps - versuchshhalber mal auf 1.8.1 upgedated - same problem)


  • 1
  • just2b just2b
    TYPO3-Yoda
    0 x
    18741 Beiträge
    2 Hilfreiche Beiträge
    06. 10. 2009, 05:57

    Hallo,

    errorwarnigs und sqldebug im install tool einschalten

    georg

  • olibert olibert
    Jedi-Ritter
    0 x
    134 Beiträge
    0 Hilfreiche Beiträge
    06. 10. 2009, 08:31

    hi georg,
    danke für die anregung (hatte ich schon gemacht).

    ausser der php-warning:

    1. Call-time pass-by-reference has been deprecated ...

    an drei stellen in der class.tx_mmforum_pi5.php

    nichts zu sehen.

    gruss
    olibert

  • olibert olibert
    Jedi-Ritter
    0 x
    134 Beiträge
    0 Hilfreiche Beiträge
    06. 10. 2009, 17:14

    hat niemand eine idee??
    ich stehe hier seit zwei tagen voll auf dem schlauch (und der kunde auf meinem hals).

    alles funktioniert, solange ich nicht eingeloggt oder admin bin.
    das kann doch irgendwie nicht sein.

    habe mittlerweile bis auf 0.1.6 downgegradet und auch schon fast alle letzthin installierten erweiterungen sukzessive deinstalliert.
    nigs hilfts.

    bin mit meinem latein am ende ...

  • olibert olibert
    Jedi-Ritter
    0 x
    134 Beiträge
    0 Hilfreiche Beiträge
    06. 10. 2009, 23:21

    ein schritt weiter.
    bin ich inzwischen wieder bei der version 1.8.1.

    diese läuft jetzt - zumindest im frontend.
    im backend lässt sich das modul nicht aufrufen (rechter frame bleibt weiss)

    im verdacht habe ich eine etwas ältere version von sg_div und sg_zfelib, die u.a. von sg_glossary benötigt werden, da diese beim *nachträglichen* dazuklinken ihrerseits den selben effekt (leere seite) produzierten. nach einem update der beiden ext. lief auf das glossary wieder.
    vielleicht spart das dem ein oder anderen die suche, bei ähnlichen effekten.

    ich setze den post nicht auf gelöst in der hoffnung, auch das be-modul von mm_forum wieder ans laufen zu bekommen.

    danke und gruss
    olibert

  • olibert olibert
    Jedi-Ritter
    0 x
    134 Beiträge
    0 Hilfreiche Beiträge
    10. 10. 2009, 12:17

    hm - ein paar probleme bleiben noch.
    wenn einmal der wurm drin ist ...

    wie erwähnt, lässt sich das forum im backend nicht mehr aufrufen (rechter frame bleibt leer). im errorlog vom server finde ich nu folgendes

    1. PHP Warning: mysql_fetch_assoc(): supplied argument is not a valid MySQL result resource in /var/www/vhosts/domehn.de/httpdocs/t3lib/class.t3lib_db.php on line 796

    und

    1. PHP Fatal error: Call to undefined method t3lib_parsehtml::substitutemarkerarray() in /var/www/vhosts/domehn.de/httpdocs/typo3conf/ext/mm_forum/mod1/class.tx_mmforum_install.php on line 279, referer: http://www.domehn.de/typo3/alt_db_navframe.php??currentSubScript=..%2Ftypo3conf%2Fext%2Fmm_forum%2Fmod1%2Findex.php

    bin phpmäßig zu unbeschlagen um hier jetzt selbst einsteigen zu können.

    vielleicht kann einer der hier anwesenden entwickler ein klein wenig licht ins dunkel bringen?

    grüsse
    olibert

  • 7th-key 7th-key
    T3PO
    0 x
    8 Beiträge
    0 Hilfreiche Beiträge
    16. 10. 2009, 14:30

    hallo,

    ich habe das gleiche problem im BE.

    mit der selben fehlermeldung

    1. PHP Fatal error: Call to undefined method t3lib_parsehtml::substitutemarkerarray() in /var/www/vhosts/domehn.de/httpdocs/typo3conf/ext/mm_forum/mod1/class.tx_mmforum_install.php on line 279, referer: http://www.domehn.de/typo3/alt_db_navframe.php??currentSubScript=..%2Ftypo3conf%2Fext%2Fmm_forum%2Fmod1%2Findex.php

    typo3 4.1.10 (with symlinks to source)
    PHP 5.2.5

    ich habe von 1.7 upgedatet.
    wenn ich die tx_mmforum_config.ts lösche, dann sehe ich wieder das backend modul, aber nach den dritten istallationsschritt (die abfrage der usergruppen), ist der BE medul wieder blank. [/code]

  • 1