fatal error - warum? [Gelöst]

  • tobilot tobilot
    R2-D2
    0 x
    66 Beiträge
    0 Hilfreiche Beiträge
    11. 10. 2008, 10:00

    Hallo
    Ich hatte versucht, Typo3 upzudaten von 4.1 auf 4.2. Es trat das Problem mit dam auf, das ich aber erst zu spät bemerkt hatte.
    Nachdem also nix mehr ging, habe ich die alten typo3 und t3lib Ordner wieder verwendet (Ich hab keinen shell Zugang, habe die Ordner via ftp hochgeladen).

    Doch jetzt kommt folgende Fehlermeldung:

    Fatal error: Class 'tx_dam' not found in /*SERVER-ROOT*/*CONTENT-ROOT*/typo3conf/temp_CACHED_ps053f_ext_tables.php on line 2028

    es sind alle _CACHED_ Files gelöscht.
    Wie bekomme ich den Aufruf in diese Datei weg? Bin leider nicht so firm in diesen Dingen?

    Vielen Dank


  • 1
  • einpraegsam.net einpraegs...
    MacGyver
    0 x
    9340 Beiträge
    80 Hilfreiche Beiträge
    11. 10. 2008, 11:42

    Hast du DAM installiert? Falls nicht, dann lösch den Eintrag aus der localconf.php raus

    in2code.de - Wir leben TYPO3
    - Möchtest du TYPO3 komplett verstehen? Eigene Erweiterungen erstellen? Bei uns gibt es auch Schulungen https://www.in2code.de/produkte/typo3-schulungen/
    - Die Arbeit mit TYPO3 macht dir Spaß? Du stehst auf Berge? Komm zu uns! https://www.in2code.de/agentur/karriere/

  • tobilot tobilot
    R2-D2
    0 x
    66 Beiträge
    0 Hilfreiche Beiträge
    11. 10. 2008, 13:29

    Ja, DAM ist installiert.
    Habe aber jetzt trotzdem mal alle Zeilen, die mit dam zu tun haben, aus der localconf versteckt mittels //

    z.b. so: //$TYPO3_CONF_VARS['EXT']['extConf']['dam'] = .........

    Leider keine Änderung. Irgendwie versucht hier der parser auf eine dam-funktion zuzugreifen, die angeblich in einer temporären Datei vorliegt. Diese sind aber alle gelöscht.
    Wo könnte ich den Aufruf wieder "gerade biegen"?

  • tobilot tobilot
    R2-D2
    0 x
    66 Beiträge
    0 Hilfreiche Beiträge
    11. 10. 2008, 13:35

    Um es nochmal strukturierter darzustellen.

    Beim Aufruf des FE kommt folgende Fehlermeldung:

    [HTML]Fatal error: Call to undefined function txdam_getMediaTCA() in /...../typo3conf/temp_CACHED_ps053f_ext_tables.php on line 2104[/HTML]

    Die temporären Dateien sind wieder erstellt, der dazugehörige Teil aus der temporären Datei mit der Zeile 2104 sieht so aus :

    1. ###########################
    2. ## EXTENSION: dam_ttcontent
    3. ## FILE: /home/simmern/htdocs/typo3/typo3conf/ext/dam_ttcontent/ext_tables.php
    4. ###########################
    5.  
    6. $_EXTKEY = 'dam_ttcontent';
    7. $_EXTCONF = $TYPO3_CONF_VARS['EXT']['extConf'][$_EXTKEY];
    8.  
    9.  
    10. if (!defined ('TYPO3_MODE')) die ('Access denied.');
    11.  
    12.  
    13. $tempColumns = array(
    14. 'tx_damttcontent_files' => txdam_getMediaTCA('image_field', 'tx_damttcontent_files')
    15. );
    16.  
    17.  
    18. t3lib_div::loadTCA('tt_content');
    19. t3lib_extMgm::addTCAcolumns('tt_content',$tempColumns,1);
    20.  
    21.  
    22. $tempSetup = $GLOBALS['T3_VAR']['ext']['dam_ttcontent']['setup'];
    23.  
    24. ## CType image
    25.  
    26. if ($tempSetup['ctype_image_add_ref']) {
    27.  
    28. if ($tempSetup['ctype_image_add_orig_field']) {
    29. t3lib_extMgm::addToAllTCAtypes('tt_content','tx_damttcontent_files','image','after:image');
    30. } else {
    31. $TCA['tt_content']['types']['image']['showitem'] = str_replace(', image;', ', tx_damttcontent_files;', $TCA['tt_content']['types']['image']['showitem']);
    32. }
    33. }
    34.  
    35. ## CType textpic
    36.  
    37. if ($tempSetup['ctype_textpic_add_ref']) {
    38.  
    39. if ($tempSetup['ctype_textpic_add_orig_field']) {
    40. t3lib_extMgm::addToAllTCAtypes('tt_content','tx_damttcontent_files','textpic','after:image');
    41. } else {
    42. $TCA['tt_content']['types']['textpic']['showitem'] = str_replace(', image;', ', tx_damttcontent_files;', $TCA['tt_content']['types']['textpic']['showitem']);
    43. }
    44. }

    wobei Zeile 2104 die folgende ist (entspricht Zeile 14 in diesem post):
    1. 'tx_damttcontent_files' => txdam_getMediaTCA('image_field', 'tx_damttcontent_files')

    Beim Aufruf des BE kommt folgende Fehlermeldung:

    [HTML]Fatal error: Class 'tx_dam' not found in /home/simmern/htdocs/typo3/typo3conf/temp_CACHED_ps053f_ext_tables.php on line 2028[/HTML]

    Der dazugehörige Code inkl der Zeile 2028 in der temporären Datei sieht so aus:

    1. ###########################
    2. ## EXTENSION: dam_index
    3. ## FILE: /home/simmern/htdocs/typo3/typo3conf/ext/dam_index/ext_tables.php
    4. ###########################
    5.  
    6. $_EXTKEY = 'dam_index';
    7. $_EXTCONF = $TYPO3_CONF_VARS['EXT']['extConf'][$_EXTKEY];
    8.  
    9.  
    10. if (!defined ('TYPO3_MODE')) die ('Access denied.');
    11.  
    12. if (TYPO3_MODE=='BE') {
    13.  
    14.  
    15. $tempSetup = unserialize($_EXTCONF);
    16.  
    17. if ($tempSetup['add_media_file_indexing']) {
    18.  
    19. t3lib_extMgm::insertModuleFunction(
    20. 'txdamM1_file',
    21. 'tx_damindex_index',
    22. t3lib_extMgm::extPath($_EXTKEY).'modfunc_index/class.tx_damindex_index.php',
    23. 'LLL:EXT:dam_index/modfunc_index/locallang.xml:tx_damindex_index.title'
    24. );
    25. }
    26.  
    27. if ($tempSetup['add_media_indexing']) {
    28. t3lib_extMgm::addModule('txdamM1','index','before:tools',t3lib_extMgm::extPath($_EXTKEY).'mod1/');
    29.  
    30. t3lib_extMgm::insertModuleFunction(
    31. 'txdamM1_index',
    32. 'tx_damindex_index',
    33. t3lib_extMgm::extPath($_EXTKEY).'modfunc_index/class.tx_damindex_index.php',
    34. 'LLL:EXT:dam_index/modfunc_index/locallang.xml:tx_damindex_index.title'
    35. );
    36. }
    37.  
    38.  
    39. tx_dam::register_indexingRule ('tx_damindex_rule_recursive', 'EXT:dam_index/lib/class.tx_damindex_rules.php:&tx_damindex_rule_recursive');
    40. tx_dam::register_indexingRule ('tx_damindex_rule_folderAsCat', 'EXT:dam_index/lib/class.tx_damindex_rules.php:&tx_damindex_rule_folderAsCat');
    41. tx_dam::register_indexingRule ('tx_damindex_rule_doReindexing', 'EXT:dam_index/lib/class.tx_damindex_rules.php:&tx_damindex_rule_doReindexing');
    42. tx_dam::register_indexingRule ('tx_damindex_rule_dryRun', 'EXT:dam_index/lib/class.tx_damindex_rules.php:&tx_damindex_rule_dryRun');
    43.  
    44. if($TYPO3_CONF_VARS['EXTCONF']['dam']['setup']['devel']) {
    45. tx_dam::register_indexingRule ('tx_damindex_rule_devel', 'EXT:dam_index/lib/class.tx_damindex_rules.php:&tx_damindex_rule_devel');
    46. }
    47.  
    48. }

    wobei Zeile 2028 dann folgende ist (enspricht Zeile 39 in diesem post):
    1. tx_dam::register_indexingRule ('tx_damindex_rule_recursive', 'EXT:dam_index/lib/class.tx_damindex_rules.php:&tx_damindex_rule_recursive');

    Tja, ich bin echt ziemlich ratlos, wie kann ich das wieder zurecht "biegen"?

  • tobilot tobilot
    R2-D2
    0 x
    66 Beiträge
    0 Hilfreiche Beiträge
    11. 10. 2008, 14:40

    Problem gelöst!
    Vergesst den ganzen Code, den ich oben gepostet habe.
    Bei der weiteren Suche hier im Forum war etwas ähnliches beschrieben. Das löschen der Einträge in der localconf habe ich gemacht. Wahrscheinlich war irgendetwas mit dam nicht mehr in Ordnung. Jedenfalls musste ich jetzt noch alle temporären Dateien löschen. Das hatte ich zwar am Anfang auch schon gemacht, aber da waren die Einträge aus der localconf noch nicht raus.

    Naja, BE und FE gehen wieder :D

    Und das Update 4.1 > 4.2.2 hat auch geklappt.

  • 1