Hintergrundfarbe der input-Felder bei IE7

  • mamo mamo
    R2-D2
    0 x
    113 Beiträge
    0 Hilfreiche Beiträge
    01. 02. 2009, 21:02

    Hallo
    Ich habe zwei Probleme mit dem csc-mailform:
    1) Die Hintergrundfarbe bei den input-Feldern lässt sich nicht anpassen. Mit [TS]fieldset.csc-mailform input{background-color:#FF0000;[/TS] lässt sich die Hintergundfarbe der Eingabefelder verändern. Das funktioniert im Firefox und im IE6. Im IE7 erscheint die gewünschte Farbe kurz beim Laden der Seite, wird aber dann mit einem hellblauen Farbton überschrieben.

    Ich habe schon verschiedene Lösungsansätze probiert:
    - diverse css-Einstellungen ausprobiert
    - im Object Browser gesucht
    - Cache im Browser und im Typo3 geleert
    - Google-Toolbar ausgeschaltet
    - Einstellungen des Browsers überprüft (z.B. ob css zugelassen werden)
    - unzählige Beiträge in Foren gelesen
    Nichts führte bisher zum gewünschten Erfolg.
    Hat jemand eine Idee, wo ich noch suchen könnte?
    Ich benutze Typo3 4.2.3 und YAML.

    2) Weiter bringe ich es nicht fertig, dass die Radio-Buttons und der dazugehörige Text auf einer Linie ausgerichtet sind. Die Buttons sind immer um ein Stück weiter oben ausgerichtet als der Text.

    Wenn ich in Zeile 5 (siehe unten) bei input den Befehl float:none durch float:left ersetze, erscheinen Punkt und Text auf derselben Höhe, dafür ist der nächste Punkt auf der neuen Zeile um ca. 50px nach rechts verschoben.

    Das ist mein CSS:
    [TS]fieldset.csc-mailform{border:0;}
    fieldset.csc-mailform label{width:120px; float:left; text-align:right; margin-right:10px; display:block;}
    fieldset.csc-mailform input{margin-bottom:10px; border:1px solid #c2c2c2; padding:2px; xwidth:250px; background-color:#FF0000;}
    fieldset.csc-mailform textarea{margin-bottom:10px; border:1px solid #c2c2c2; padding:2px; xwidth:250px; background-color:#FF0000;}
    fieldset.csc-mailform fieldset input{float:none; display:inline; width:50px; text-align:left; border:0; background:none;}
    fieldset.csc-mailform fieldset label{display:inline; float:none; text-align:left; width:300px; margin:0px 0}
    fieldset.csc-mailform fieldset{border:0}
    fieldset.csc-mailform fieldset legend{display:none;}
    fieldset.csc-mailform select{width:220px; margin:2px 0;}
    fieldset.csc-mailform option{padding:0 5px; background:#fff;}
    #mailformformtype_mail{padding:2px;margin-left:40px; background:#eee; border:1px solid #ccc; width:80px; text-align:center;}[/TS]

    - Die Textarea erscheint wie gewünscht rot, die Radio-Buttons haben
    keine Hintergrundfarbe. Die Input-Felder erscheinen nach wie vor hellblau.
    - Radio-Buttons und Text erscheinen fast nebeneinander, aber um Button-Höhe verschoben.

    Weiss jemand Rat? Vielen Dank
    Gruss
    mamo


  • 1
  • mamo mamo
    R2-D2
    0 x
    113 Beiträge
    0 Hilfreiche Beiträge
    20. 02. 2009, 16:53

    Bin ich die einzige mit diesem Problem? Sonderbar!

    Unterdessen habe ich herausgefunden, dass die hellblaue Farbe nur den Feldern "Name" und "EMail" zugeordnet wird. Mit Feldbezeichnungen "Nachname" und "Mail" kann ich das umgehen. Trotzdem möchte ich wissen, wo so etwas definiert sein könnte.
    Wo stecken noch weitere Konfigurationen zum Mailform?
    Oder hat das doch mit dem IE7 zu tun?

  • 1