Datum + Wochentag in deutsch [Gelöst]

  • MaLe MaLe
    Padawan
    0 x
    39 Beiträge
    0 Hilfreiche Beiträge
    22. 09. 2006, 15:25

    Hallo

    Ich sollte das Datum erweitern. Vorher z.Bsp "22.09.2006". Sollte jetzt "Freitag, 22.09.2006" haben.

    Im TypoScript hatte ich:
    [TS]10 = TEXT
    10.data = date:d.m.Y
    [/TS]

    Neu habe ich ganz einfach
    [TS]10 = TEXT
    10.data = date:l, d.m.Y
    [/TS]

    Soweit sogut, nun ist aber auf English (Friday, 22.09.2006). Ich dachte alles ist so einfach. Habe im Template "fast" alles Versucht:
    [TS]config.language = de
    config.locale_all = de_DE
    config.language = de
    config.locale_all = de_DE.iso88591
    [/TS]
    usw.
    alles ohne erfolg. Ich weiss nicht an was das liegt. Dies läuft auf meiner Testumgebung: Windows localhost xampp 1.5.3.a Typo3 3.8.0.

    Was muss ich noch Einstellen, habe das csh_de istalliert und alles ist eigentlich auf Deutsch. Das Problem ist mir bis heute eigentlich auch nicht aufgefallen.

    Gruss
    MaLe


  • chris3 chris3
    Sternenflotten-Admiral
    0 x
    229 Beiträge
    0 Hilfreiche Beiträge
    22. 09. 2006, 16:29

    ... wenn typo3 das Datum über die PHP date() Funktion ausliest, mußt Du da ansetzten ... ist halt die Frage : "Bekommt typo3 das Datum schon in Englisch, oder 'übersetzt' es das Datum selbständig" ?

    EDIT :[url=http://codefreak.de/archiv/2005/04/13/datumsformatierung-in-typo3-ein-alptraum/]
    Datumsformatierung in Typo3 - Ein Alptraum[/url]
    Datum einfügen

    ... vieleicht hilft ja was ...

  • MaLe MaLe
    Padawan
    0 x
    39 Beiträge
    0 Hilfreiche Beiträge
    22. 09. 2006, 17:10

    Hi

    Wie ist das den bei Dir, in welcher Sprache bekommt Typo3 das Datum?
    Wie gibst Du in Typo3 den aktuellen Wochentag den im FE aus?

    Die links haben mir nicht geholfen, sie haben nur die problematiken beschrieben mit denen ich mich heute schon rumgeschlagen habe.

    Gruss
    MaLe

  • toyde toyde
    Jedi-General
    0 x
    1971 Beiträge
    0 Hilfreiche Beiträge
    22. 09. 2006, 17:41

    Setup:
    [TS]config.language = de
    config.locale_all = de_DE[/TS]
    Ausgabe-Konfiguration(Beispiel):
    [TS]### DATUM
    temp.datum.10 = TEXT
    temp.datum.10.data = date:U
    temp.datum.10.strftime = %A, %d.%m.%Y[/TS]
    Frontend, gerade getestet:

    Freitag, 22.09.2006

    Verfolgt man die Geschichte über Google, scheint über PHP de_DE@euro auch eine Rolle zu spielen. Falls obiges nicht funktioniert, kommt man darüber evtl. weiter.
    1. setlocale (LC_ALL, 'de_DE@euro', 'de_DE', 'de', 'ge');

    grüsse

  • MaLe MaLe
    Padawan
    0 x
    39 Beiträge
    0 Hilfreiche Beiträge
    22. 09. 2006, 18:02

    Hi

    Habe das nochmals versucht:
    [TS]config.language = de
    config.locale_all = de_DE
    [/TS]
    und
    [TS]10 = TEXT
    10.data = date:U
    10.strftime = %A, %d.%m.%Y
    [/TS]
    habe noch weiter mit de_DE@euro, de_ch (da ich aus der Schweiz bin) usw. ohne erfolg.

    Wo meinst Du den das der PHP code reinkommt?

    Weiss wirklich nicht mehr weiter.

    Gruss
    MaLe

  • toyde toyde
    Jedi-General
    0 x
    1971 Beiträge
    0 Hilfreiche Beiträge
    22. 09. 2006, 18:27

    habe noch weiter mit de_DE@euro, de_ch (da ich aus der Schweiz bin) usw. ohne erfolg.
    mitdenken könnte man schon . Oben gepostete Syntax funktioniert(dass mein Server auch in der Schweiz steht, spielt hier keine Rolle ;p) - nur mit rumprobieren kommt man nicht besonders weit, falls Du zusätzliche Configs durchgeführt hast.

    Hast Du zusätzliche Sprachen installiert? Poste mal dein ganzes TypoScript ins Forum.

    grüsse

  • jenses jenses
    Flash Gordon
    0 x
    2559 Beiträge
    27 Hilfreiche Beiträge
    22. 09. 2006, 20:29

    Unter Windows sollte es mit:
    [TS]config.locale_all = German_Germany.1252[/TS]
    funktionieren.

  • MaLe MaLe
    Padawan
    0 x
    39 Beiträge
    0 Hilfreiche Beiträge
    23. 09. 2006, 19:07

    @jenses
    Geht bei meiner lokalen (Win mit XAMPP) installation auch nicht.

    @toyde

    Etwas mitdenken könnte man schon

    Ich glaube das ich schon mitdenke. Ich wollte Dir auch nicht Unterstellen das Dein Syntax schlecht ist.
    Das mit der Schweiz meinte ich auch in bezug das es einen lokalen Win Computer mit XAMPP für Win ist und ich das problem eher bei der PHP installation vermute.

    Ich weiss nicht ob es möglich ist das etwas mit den PHP Charset nicht funktioniert den ich habe mal versucht (nur zum Testen) die Sprache auf französisch Umzustellen - das ging auch nicht.

    Ich Such mal in der richtung PHP weiter.

    Gruss
    MaLe

  • toyde toyde
    Jedi-General
    0 x
    1971 Beiträge
    0 Hilfreiche Beiträge
    23. 09. 2006, 20:13

    Poste die PHP-Info in's Forum was bei Dir in der Zusammenfassung drin steht. Du kannst sie lokal direkt aufrufen. Ansonsten geht's auch über InstallTool unter "8. phpinfo()".

    Eine installierte deutsche Sprache(Backend) ist im Bezug auf chris3's Bemerkung evtl. relevant. Auf genanntem Beispiel meinerseits ist/war keine weitere Sprache installiert.

    Probier diese Einstellung durch. Mein obiger Code stammt aus dem letzten Post.
    Weiter wird darin diese Seite genannt.

    grüsse

  • MaLe MaLe
    Padawan
    0 x
    39 Beiträge
    0 Hilfreiche Beiträge
    24. 09. 2006, 16:41

    Hier einen kleinen Ausschnitt aus der phpinfo die einen zusammenhang haben könnte:

    date
    date/time support enabled
    Timezone Database Version 2006.1
    Timezone Database internal
    Default timezone Europe/Paris

    Directive Local Value Master Value
    date.default_latitude 31.7667 31.7667
    date.default_longitude 35.2333 35.2333
    date.sunrise_zenith 90.583333 90.583333
    date.sunset_zenith 90.583333 90.583333
    date.timezone no value no value

    Directive Local Value Master Value
    iconv.input_encoding ISO-8859-1 ISO-8859-1
    iconv.internal_encoding ISO-8859-1 ISO-8859-1
    iconv.output_encoding ISO-8859-1 ISO-8859-1

    Multibyte Support enabled
    Multibyte string engine libmbfl
    Multibyte (japanese) regex support enabled
    Multibyte regex (oniguruma) version 3.7.1

    Directive Local Value Master Value
    mbstring.detect_order no value no value
    mbstring.encoding_translation Off Off
    mbstring.func_overload 0 0
    mbstring.http_input pass pass
    mbstring.http_output pass pass
    mbstring.internal_encoding no value no value
    mbstring.language neutral neutral
    mbstring.strict_detection Off Off
    mbstring.substitute_character no value no value

    Gruss
    MaLe

  • MaLe MaLe
    Padawan
    0 x
    39 Beiträge
    0 Hilfreiche Beiträge
    25. 09. 2006, 12:27

    Das Problem ist gelöst:
    Ich habe viel zu weit gesucht und die Unsicherheit auf einem Win Rechner haben mir den Überblick geraubt.

    Ich musste die Sprache mit:
    [TS]config.locale_all=des
    [/TS]
    einstellen siehe für Win dies http://msdn.microsoft.com/library/default.asp?url=/library/en-us/vclib/html/_crt_language_strings.asp
    im weiteren wird in PHP 'date' nicht Übersetzt.
    Dazu muss 'date:U', also date ab der UNIX Epoche, verwendet werden und mit 'strftime = %A, %d. %B %Y' die ausgabe definiert werden, hier TSconfig Schnippsel:
    [TS]...
    10 = TEXT
    10.data = date:U
    10.strftime = %A, %d. %B %Y
    ...
    [/TS]

    MaLe