Verzweifle an Änderung der TextPic Wraps [Gelöst]

  • 0 x
    12 Beiträge
    0 Hilfreiche Beiträge
    25. 08. 2012, 15:48

    Hallo zusammen,

    wäre schön, wenn mir jemand helfen könnte - eigentlich dachte ich, dass ich die Grundlagen verstanden habe
    Auch waren mir alle bisherigen Forenbeiträge keine Hilfe...

    So sieht die Vorgabe im css_styled_content-Template aus:

    1. 766: tt_content.textpic = COA
    2. 767: tt_content.textpic {
    3. 768: 10 = COA
    4. 769: 10.if.value = 25
    5. 770: 10.if.isLessThan.field = imageorient
    6. 771: 10.10 = < lib.stdheader
    7. 772:
    8. 773: 20 = < tt_content.image.20
    9. 774: 20 {
    10. 775: text.10 = COA
    11. 776: text.10 {
    12. 777: if.value = 24
    13. 778: if.isGreaterThan.field = imageorient
    14. 779: 10 = < lib.stdheader
    15. 780: 10.stdWrap.dataWrap = <div class="csc-textpicHeader csc-textpicHeader-{field:imageorient}">|</div>
    16. 781: }
    17. 782: text.20 = < tt_content.text.20
    18. 783: text.wrap = <div class="csc-textpic-text"> | </div>
    19. 784: }
    20. 785: }

    Wenn ich also was an dem stdWrap in Zeile 780 ändern möchte (testweise nur der Name), dann müsste das doch so funktionieren (im root-Template):

    1. tt_content.textpic >
    2. tt_content.textpic = COA
    3. tt_content.textpic {
    4. 10 = COA
    5. 10.if.value = 25
    6. 10.if.isLessThan.field = imageorient
    7. 10.10 = < lib.stdheader
    8.  
    9. 20 = < tt_content.image.20
    10. 20 {
    11. text.10 = COA
    12. text.10 {
    13. if.value = 24
    14. if.isGreaterThan.field = imageorient
    15. 10 = < lib.stdheader
    16. 10.stdWrap.dataWrap = <div class="ANDERER NAME csc-textpicHeader csc-textpicHeader-{field:imageorient}">|</div>
    17. }
    18. text.20 = < tt_content.text.20
    19. text.wrap = <div class="ANDERER NAME"> | </div>
    20. }
    21. }

    Oder habe ich da etwas falsch verstanden? Es ändert sich nämlich nichts in der Ausgabe.

    Selbst wenn ich mit

    1. tt_content.textpic >

    alle Defaultvorgaben lösche bleibt alles beim Alten - als ob ich nichts gemacht hätte...

    - alle Caches wurden gelöscht (inkl. Konfigurationscache)
    - in keinem weiteren Template wird tt_content wieder überschrieben (das Ergebnis bleibt auch dasselbe, wenn ich das Ganze direkt im Erweiterungstempate der eigentlichen Seite mache)

    Habe ich irgendetwas übersehen oder falsch verstanden!?

    Vielen Dank schonmal


  • 1
  • 0 x
    12 Beiträge
    0 Hilfreiche Beiträge
    25. 08. 2012, 15:59

    Hat sich erledigt - das Script stimmt und funktioniert... irgendwie leert sich der Cache nicht so wie ich das will Daran lags.

  • 1