16. 06. 2012, 19:08

Hallo, ich komme einfach nicht weiter, vielleicht kann mir jemand helfen
Ich habe eine Seite (TYPO3 4.5.16, TemplaVoilá 1.7.0) mit mehrere Sprachen, Single Tree Concept, Übersetzungen "bound" in TV.

Auf einer Unterseite habe ich 3 Content-Elemente (keine davon FCEs)
- A) Text, lokalisiert, über TV übersetzt (bound)
- B) Bild (Language: all)
- C) Text, lokalisiert, nur default-Language, nicht übersetzt

Ziel soll sein:
Es sollen bei den Sprachen nur Elemente ohne Lokalisierung und übersetzte Elemente angezeigt werden (in meinem Fall): A,B

Aktuelles Verhalten (ich habe jezt alle sinnigen und unsinnigen Konfigurationen durch, komme aber immer nur auf diese Lösungen):
- Es wird bei Seiten der "nicht-default-Language" gar nichts angezeigt
- Es wird A übersezt angezeigt, B, und C in default Sprache (und C soll eben NICHT angezeigt werden)

Aktuelle Config:

  1. config.sys_language_mode = strict
  2. config.sys_language_overlay = 1

> Zeigt A übersetzt, B, C in default-Language
sobald ich config.sys_language_overlay = hideNonTranslated setzte, bekomme ich gar nichts mehr angzeigt

DS der Seitenvolage (XML):

  1. <meta type="array">
  2. <langChildren type="integer">1</langChildren>
  3. <langDisable type="integer">1</langDisable>
  4. </meta>

Bei langChildren muss es ja true sein (bound), bei langDisable ändert sich nichts, egal ob true oder false...

Hier meine Quellen zur Problemlösung - ja ich habe gegoogelt und bin dennoch zu dumm
- http://www.typo3-media.com/blog/article/mehrsprachigkeit-und-templavoila.html
- http://wiki.typo3.org/TemplaVoila#TemplaVoila_working_with_multiple_languages
- http://www.npostnik.de/typo3/single-tree-sprachsetup-in-templavoila/
- http://www.typo3.net/forum/beitraege/mehrsprachigkeit/101353/
- http://typo3.org/documentation/document-library/core-documentation/doc_core_tsref/4.1.0/view/7/3/