14. 06. 2012, 19:44

Letze Ergänzung,

obwohl die Extension sp_bettercontact nicht auf: http://wiki.typo3.org/TYPO3_4.7

als inkompatibel ab Version 4.7 gelistet ist, ist dem so.

Siehe auch:

http://forge.typo3.org/issues/37093

Soll sp_bettercontact mit T3 ab 4.7.x laufen, muss man in die localconf.php

  1. $GLOBALS['TYPO3_CONF_VARS']['MAIL']['substituteOldMailAPI'] = 1

eintragen. Dies ist sicher nicht im Sinne der Evolution von T3. Ich hoffe, dass die Extension fit für die Zukunft gemacht wird.

sp_bettercontact gehört zu den Extensions, welche immer sofort liefen und über ein sehr gutes Manual verfügen. Hervorzuheben ist auch die Intergration der verschiedenen Captchas, welche de facto ohne Eingriffe sofort laufen. Eben was für Anticonfigurationsfreaks. Es wäre schade, wenn es diese EXT nicht mehr gäbe.

---------------------------------

Hallo,

ganz frische T3-Installation (4.7.1 und nur die frischsten Extensions). sp_bettercontact installiert, nichts an den Grundeinstellungen geändert. Nach dem Absenden zeigt der IE9 eine leere Seite, Opera findet die Seite nicht. Beide geben ein HTTP 500, obwohl der richtige Pfad zur Seite in der Adressleiste steht.

5 mal das Manual zur Extensionm gelesen.

Ok, zum Testen der Mailfunktionen habe ich ein ganz normales T3ßStandardformular erstellt. Dieses funktioniert immer. Ausgetestet wurde auch der Versand über die php-Mailfunktion und Sendmail, beides funktioniert.

Hab ich irgendeine Einstellung übersehen?

Alle aktiven nicht standardmäßig aktivierten Extensions:

...

Über eine Lösung wäre ich sehr erfreut, da ich darüber schon eine Weile sitze und die EXT bettercontact so einen guten Eindruck macht.

Grüße Thomas Weber

Ergänzung von heute: Habe die Fehlermeldungen eingeschaltet:

Fatal error: Class 't3lib_htmlmail' not found in /home/clients/chroot/home/thomas/typo3_aster/test.a-ster.pl/typo3_src-4.7.1/t3lib/class.t3lib_div.php on line 4847

Diesbezüglich fand ich hier im selbem Forum unter:

http://www.typo3.net/forum/beitraege/formulare/110631/

die Aussage, dass "htmlmail Klasse gibt es ab 4.7 nicht mehr - daher vermutlich auch die Fehlermeldung" - wäre dem so, müsste vielleicht bettercontact geupdatet werden? Die Datei mit der htmlklasse gibt es allerdings physisch noch unter dem SRC-Folder.

Habe dieselbe Konfiguration heute auch auf T3 4.5 LTS gestestet, dort funktioniert alles bestens, auf 4.7.1 komme ich nicht weiter.

Was nun?