Problem mit Quickshop

  • 0 x
    26 Beiträge
    0 Hilfreiche Beiträge
    04. 05. 2012, 09:26

    Hallo an alle!

    Bisher hat mir dieses Forum schon viel geholfen, daher traue mich mich mal, meine hoffenltich nicht allzu dumme Frage zu stellen...

    Kurz die Vorgeschichte: Habe Quickshop installiert und alles soweit zum laufen gekriegt *stolzguck*... nur im letzten Schritt, wo die Bestellung abgeschickt werden soll, kommt folgender Fehler:
    "Address in mailbox given [] does not comply with RFC 2822, 3.6.2."
    Die E-mail Adresse ist auf jeden Fall richtig, ich hab es auch mit anderen funktionierenden Adressen mal probiert. Nichts hilft. Über google bin ich auf einige Foreneinträge gestoßen, in denen steht, man soll in der Datei:

    typo3/contrib/swiftmailer/classes/Swift/Mime/Headers/MailboxHeader.php

    ein paar Zeilen auskommentieren.

    Jetzt die Frage: Wo liegt diese Datei? Wie finde ich die? Ich hab überhaupt keinen Plan davon, wo ich da was suchen soll

    Könnt ihr mir (eine möglichst kleinschrittige) Anleitung geben?
    Vielen Dank schonmal!

    Nekomancer


  • 1
  • LuP LuP
    Jedi-Meister
    0 x
    496 Beiträge
    0 Hilfreiche Beiträge
    04. 05. 2012, 11:47

    Hallo,

    der Fehler tritt unter anderem auf, wenn Absender-/Empfängername bzw. Absender-/Empfänger-E-Mail nicht vollständig sind. Evtl. die Einstellungen im powermail plugin (Reiter sender und recipients) bzw. in den TS-Constants noch einmal prüfen.

    VG,
    LuP

  • 0 x
    26 Beiträge
    0 Hilfreiche Beiträge
    04. 05. 2012, 13:34

    Hallo LuP,

    die Adressen sind beide gültig, daran scheint es nicht zu liegen...
    Trotzdem danke!

    Kann es sein, dass ich über meinen ganz normalen Typo3 -Zugang gar nicht auf auf besagte typo3/contrib/swiftmailer/classes/Swift/Mime/Headers/MailboxHeader.php -Datei zugreifen kann? Geht das evtl. nur direkt über den Server, wo die Datei irgendwo liegt?

  • 0 x
    26 Beiträge
    0 Hilfreiche Beiträge
    05. 05. 2012, 18:28

    Hallo!

    Besagte Datei liegt wirklich auf dem Server, an den ich selbst nicht "randarf". Ich habe die Zeilen also auskommentieren lassen, die Fehlermeldung veschwand auch...
    Aber die Bestellung wird einfach nicht abgeschickt.

    Kennt irgendjemand dieses Problem mit Quickshop?

  • 0 x
    26 Beiträge
    0 Hilfreiche Beiträge
    08. 05. 2012, 20:16

    Hallo nochmal

    Ich konnte das Problem zwar nicht lösen, habe aber erstmal eine Alternative gefunden

    Ich habe über einen HTML Generator einen Shop erstellen lassen und diesen als reines HTML-Element eingefügt. Jetzt habe ich einen Shop. Nur ist es eben kein Quickshop.

    Vielleicht findet aber trotzdem jemand eine Lösung für das Problem, es wäre ja schön, zu wissen, was ich hätte besser machen können...

    Vielen Dank an LuP und alle anderen, die mitgelesen und -gedacht haben :-)

    Nekomancer

  • 1