Workspace Email-Benachichtigung auf deutsch

  • kambego kambego
    T3PO
    0 x
    14 Beiträge
    0 Hilfreiche Beiträge
    02. 11. 2011, 10:39

    Hi,

    ich nutze den Workspace ab Typo3 Version 4.5., es funktioniert auch alles, nur würde ich gerne die Email-Benachichtigungen, die der Workspace versendet auch auf deutsch versenden lassen, kann mir da jemand helfen wo dafür die Einstellungen gemacht werden müssen,

    Danke


  • 1
  • marsu_2 marsu_2
    T3PO
    0 x
    19 Beiträge
    0 Hilfreiche Beiträge
    09. 10. 2012, 12:22

    Auch wenn das Ticket schon älter ist dachte ich mir ich hänge meine Frage an die bestehende bevor ich ein neues Thema öffne.

    Es gibt einige Themen bezüglich der Umstellung auf einen deutschen Email Versand. Diese sind aber für die aktuelle Typo Version nicht mehr gültig.

    Meine Version ist Typo3 4.7 mit dem Government Package.

    Ich würde auch gerne die Emails, die Typo mit den Stages der Workspaces verschickt, eindeutschen.

    Ich habe dafür zwei Dateien gefunden die den gleichen Inhalt beherbergen. Wo der Unterschied liegt kann ich nicht wirklich erkennen und wenn ich die Dateien anpasse kommt die Fehlermeldung:

    1. router
    2. The path provided does not point to existing and accessible well-formed XML file.

    Ich verstehe nicht wirklich warum Typo die Datei auf einmal nicht mehr lesen kann und ich bin mir auch nicht sicher welche datei die richtige ist.

    Kann mir da jemand helfen?

    Lieben Dank&Gruß

    Die Dateien sind:

    C:\TYPO3_4.7.4\htdocs\Government\typo3\sysext\version\Resources\Private\Language\locallang_emails.xlf

    C:\TYPO3_4.7.4\htdocs\Government\typo3conf\l10n\de\version\Resources\Private\Language\de.locallang_emails.xlf

    Das Original:

    1. <?xml version='1.0' encoding='utf-8'?>
    2. <xliff version="1.0">
    3. <file source-language="en" datatype="plaintext" original="messages" date="2011-10-17T20:22:37Z" product-name="version" target-language="de">
    4. <header/>
    5. <body>
    6. <trans-unit id="subject" xml:space="preserve">
    7. <source>TYPO3 Workspace Note: Stage Change for ###ELEMENT_NAME###</source>
    8. </trans-unit>
    9. <trans-unit id="message" xml:space="preserve">
    10. <source>At the TYPO3 site "###SITE_NAME###" (###SITE_URL###)
    11. in workspace "###WORKSPACE_TITLE###" (###WORKSPACE_UID###)
    12. the stage has changed for the element(s) "###RECORD_TITLE###" (###ELEMENT_NAME###) at location "###RECORD_PATH###" in the page tree:
    13.  
    14. =&gt; ###NEXT_STAGE###
    15.  
    16. User Comment:
    17. "###COMMENT###"
    18.  
    19. State was changed by ###USER_FULLNAME### (username: ###USER_USERNAME###)</source>
    20. </trans-unit>
    21. </body>
    22. </file>
    23. </xliff>

    Meine Version:

    1. <?xml version='1.0' encoding='utf-8'?>
    2. <xliff version="1.0">
    3. <file source-language="en" datatype="plaintext" original="messages" date="2011-10-17T20:22:37Z" product-name="version" target-language="de">
    4. <header/>
    5. <body>
    6. <trans-unit id="subject" xml:space="preserve">
    7. <source>Orga-Handbuch Bearbeitungshinweis für Dokument ###ELEMENT_NAME###</source>
    8. </trans-unit>
    9. <trans-unit id="message" xml:space="preserve">
    10. <source>Es liegt eine Aenderung im "###SITE_NAME###" (###SITE_URL###)
    11. im Arbeitsbereich "###WORKSPACE_TITLE###" vor.
    12. Es ist eine Veraenderung am Dokument "###RECORD_TITLE###" (###ELEMENT_NAME###) im Verzeichnissbaum "###RECORD_PATH###"
    13. vorgenommen worden.
    14.  
    15. Bearbeitungsstufe: ###NEXT_STAGE###
    16.  
    17. Bearbeitungshinweis des Mitarbeiters ###USER_FULLNAME### (username: ###USER_USERNAME###):
    18. "###COMMENT###"
    19. </source>
    20. </trans-unit>
    21. </body>
    22. </file>
    23. </xliff>

  • LuP LuP
    Jedi-Meister
    0 x
    496 Beiträge
    0 Hilfreiche Beiträge
    09. 10. 2012, 13:02

    Hallo,

    [quote="marsu_2"]
    The path provided does not point to existing and accessible well-formed XML file.
    [/quote]
    liegt daran:

    [quote="marsu_2"]
    <source>Orga-Handbuch Bearbeitungshinweis für Dokument ###ELEMENT_NAME###</source>
    [/quote]
    VG,
    LuP

  • marsu_2 marsu_2
    T3PO
    0 x
    19 Beiträge
    0 Hilfreiche Beiträge
    09. 10. 2012, 13:55

    Die Antwortzeiten sind genial.

    Wo ist mein Fehler in der Betreffzeile? Ich würde den Betreff der Email schon gerne ändern.

    Dank&Gruß

  • LuP LuP
    Jedi-Meister
    0 x
    496 Beiträge
    0 Hilfreiche Beiträge
    09. 10. 2012, 14:18

    so wie bei den anderen: Umlaut auflösen.

    VG,
    LuP

  • marsu_2 marsu_2
    T3PO
    0 x
    19 Beiträge
    0 Hilfreiche Beiträge
    09. 10. 2012, 15:05

    bin ich blind?

    1. Orga-Handbuch Bearbeitungshinweis für Dokument ###ELEMENT_NAME###

    ich habe es auch ohne und mit Bindestrich probiert.

  • LuP LuP
    Jedi-Meister
    0 x
    496 Beiträge
    0 Hilfreiche Beiträge
    09. 10. 2012, 16:23

    Entweder löst Du den Umlaut auf oder nutzt UTF-8 encoding.

    <source>Orga-Handbuch Bearbeitungshinweis [color=red]fuer[/color] Dokument ###ELEMENT_NAME###</source>

    VG,
    LuP

  • marsu_2 marsu_2
    T3PO
    0 x
    19 Beiträge
    0 Hilfreiche Beiträge
    10. 10. 2012, 10:08

    ich bin blind! "fü" ich habe es einfach nicht gesehen danke.

  • 1