Probleme mit Seite Bearbeiten nach Update auf 4.6.0 [Gelöst]

  • bagstage bagstage
    T3PO
    0 x
    17 Beiträge
    0 Hilfreiche Beiträge
    26. 10. 2011, 15:17

    Hallo,

    nach dem Update auf die Version 4.6.0 gibt es leider folgendes Problem..

    Wenn ich auf "Bearbeiten" klicke um eine Seite zu bearbeiten erscheint folgende Fehlermeldung:

    1. PHP Catchable Fatal Error: Argument 2 passed to t3lib_div::array_merge_recursive_overrule() must be an array, null given, called in /html/typo3_src-4.6.0/typo3/sysext/lang/lang.php on line 554 and defined in /html/typo3_src-4.6.0/t3lib/class.t3lib_div.php line 1867

    Bei den Datensätzen / Inhalten einer Seite funktioniert der "Bearbeiten" klick...

    LG
    Stefan


  • Chrissli Chrissli
    Jedi-Ratsmitglied
    0 x
    710 Beiträge
    9 Hilfreiche Beiträge
    27. 10. 2011, 08:43

    Hast du dein repository aktualisiert und
    mal Updates ( auch von den Sprachen ) geladen?

    God's in his heaven, all's right with the world

  • bagstage bagstage
    T3PO
    0 x
    17 Beiträge
    0 Hilfreiche Beiträge
    27. 10. 2011, 08:54

    Habe alle Erweiterungen aktualisiert.

    Im Install Tool habe ich auch nach Updates geschaut unter Upgrade Wizard. Hier scheint es auch ein Problem zu geben...

    ---------
    Deprecated RTE properties in Page TSconfig

    The following Page TSconfig RTE properties are deprecated since TYPO3 4.6 and will be removed in TYPO3 4.8.

    You are currently using some of these properties on 1 pages (including deleted and hidden pages).

    Pages id's: 434

    This wizard cannot update the following properties, some of which are present on those pages:.......
    ---------

    vielleicht hängt das mit der "Bearbeiten" Fehlermeldung zusammen?

    lg

  • nobbie nobbie
    R2-D2
    0 x
    112 Beiträge
    0 Hilfreiche Beiträge
    27. 10. 2011, 09:25

    Hallo bagstage,

    ich habe die selben Probleme mit "Seiten bearbeiten", obwohl das Update im Installtool ohne Probleme ablief.

    Der Kundenservice von "Mittwald" gab mir folgende Antwort:

    Bitte warten Sie noch ab bis eine neuere Version verfügbar ist, da es mit der 4.6.0 noch zu Einschränkungen kommt.

    nobbie

  • bagstage bagstage
    T3PO
    0 x
    17 Beiträge
    0 Hilfreiche Beiträge
    27. 10. 2011, 09:46

    hm, na dann hoffe ich mal das ein update schnell kommt...

  • bagstage bagstage
    T3PO
    0 x
    17 Beiträge
    0 Hilfreiche Beiträge
    27. 10. 2011, 12:42

    Kann mir denn jemand bei dieser Aussage weiterhelfen?

    1. Deprecated RTE properties in Page TSconfig
    2. The following Page TSconfig RTE properties are deprecated since TYPO3 4.6 and will be removed in TYPO3 4.8.
    3.  
    4. Deprecated property Use instead
    5. disableRightClick contextMenu.disable
    6. disableContextMenu contextMenu.disable
    7. hidePStyleItems buttons.formatblock.removeItems
    8. hideFontFaces buttons.fontstyle.removeItems
    9. fontFace buttons.fontstyle.addItems
    10. hideFontSizes buttons.fontsize.removeItems
    11. classesCharacter buttons.textstyle.tags.span.allowedClasses
    12. classesParagraph buttons.blockstyle.tags.div.allowedClasses
    13. classesTable buttons.blockstyle.tags.table.allowedClasses
    14. classesTD buttons.blockstyle.tags.td.allowedClasses
    15. classesImage buttons.image.properties.class.allowedClasses
    16. classesLinks buttons.link.properties.class.allowedClasses
    17. blindImageOptions buttons.image.options.removeItems
    18. blindLinkOptions buttons.link.options.removeItems
    19. defaultLinkTarget buttons.link.properties.target.default
    20. fontSize buttons.fontsize.addItems
    21. RTE.default.classesAnchor RTE.default.buttons.link.properties.class.allowedClasses
    22. RTE.default.classesAnchor.default.[link-type] RTE.default.buttons.link.[link-type].properties.class.default
    23. mainStyleOverride contentCSS
    24. mainStyleOverride_add.[key] contentCSS
    25. mainStyle_font contentCSS
    26. mainStyle_size contentCSS
    27. mainStyle_color contentCSS
    28. mainStyle_bgcolor contentCSS
    29. inlineStyle.[any-keystring] contentCSS
    30. ignoreMainStyleOverride n.a.
    31. disableTYPO3Browsers buttons.image.TYPO3Browser.disabled and buttons.link.TYPO3Browser.disabled
    32. showTagFreeClasses buttons.blockstyle.showTagFreeClasses and buttons.textstyle.showTagFreeClasses
    33. disablePCexamples buttons.blockstyle.disableStyleOnOptionLabel and buttons.textstyle.disableStyleOnOptionLabel
    34.  
    35. You are currently using some of these properties on 1 pages (including deleted and hidden pages).
    36. Pages id's: 434
    37. This wizard cannot update the following properties, some of which are present on those pages:
    38. Deprecated property
    39. fontSize
    40. RTE.default.classesAnchor
    41. RTE.default.classesAnchor.default.[link-type]
    42. mainStyleOverride
    43. mainStyleOverride_add.[key]
    44. mainStyle_font
    45. mainStyle_size
    46. mainStyle_color
    47. mainStyle_bgcolor
    48. inlineStyle.[any-keystring]
    49. ignoreMainStyleOverride
    50. disableTYPO3Browsers
    51. showTagFreeClasses
    52. disablePCexamples
    53. Therefore, the Page TSconfig column of those pages will need to be updated manually.
    54. Only page records were searched for deprecated properties. However, such properties can also be used in BE group and BE user records (prepended with page.). These are not searched nor updated by this wizard.
    55. Page TSconfig may also be included from external files. These are not updated by this wizard. If required, the update will need to be done manually.
    56. Note also that deprecated properties have been replaced in default configurations provided by htmlArea RTE

  • nobbie nobbie
    R2-D2
    0 x
    112 Beiträge
    0 Hilfreiche Beiträge
    28. 10. 2011, 07:10

    [quote="bagstage"]
    hm, na dann hoffe ich mal das ein update schnell kommt...
    [/quote]

    Hallo bagstage,

    stelle die BE-Sprache auf "Englisch" und die Fehlermeldung ist weg.

    nobbie

  • jansch jansch
    T3PO
    0 x
    26 Beiträge
    0 Hilfreiche Beiträge
    10. 11. 2011, 10:13

    Hallo Zusammen,

    bin hier gerade drauf gestoßen und vielleicht hilft es ja dem einen oder anderen. Das Problem wird in 4.6.1 gefixt. Mehr dazu im Bug:
    http://forge.typo3.org/issues/31353

    sg! Jan

  • plaas plaas
    T3PO
    0 x
    9 Beiträge
    0 Hilfreiche Beiträge
    07. 05. 2012, 16:44

    Hatte den identischen Fehler in Version 4.7 nach Einbau der Suche. (indexed_search)

    Die Lösung ist jedoch nicht der oben erwähnte Bug, sondern die neue form Extension.

    nach deren Deaktivierung läuft indexed search. Dies scheint eine Inkompatibilität zu sein.

  • gtr gtr
    Jar Jar Binks
    0 x
    1 Beiträge
    0 Hilfreiche Beiträge
    29. 05. 2012, 16:43

    Habe das gleiche Problem in Typo 4.7.

    Fehler trat auf der index.php Seite beim login auf, somit kein login möglich.

    In Zeile 529 von
    /html/typo3/sysext/lang/lang.php ist $tempLL[$language] bool(false)

    habe die Abfrage in Zeile 526 von
    if ($this->lang !== 'default' && isset($tempLL[$language]))
    auf
    if ($this->lang !== 'default' && is_array($tempLL[$language]))
    geändert, damit war ein login wieder möglich, jedoch keine Beschriftungen auf den Buttons.

    Nachdem ich die gesammelten caches geleert hatte, war die Beschriftung im Login-Fenster auch wieder OK.

  • Billix Billix
    Sternenflotten-Admiral
    0 x
    171 Beiträge
    0 Hilfreiche Beiträge
    30. 05. 2012, 03:47

    wollte gerade auf 4.7.1 updaten...
    Bug ist nicht behoben,...

    Beim BE-Login bekomme ich diese Fehlermeldung ebenfalls beim Upgrade Wizard...

    alle Lösungsansätze ausprobiert jedoch ohne Erfolg
    hat wer noch eine weiter Lösung