typo3 4.5.2 auf UTF-8 umstellen

  • andres andres
    Jedi-Meister
    0 x
    477 Beiträge
    0 Hilfreiche Beiträge
    11. 04. 2011, 20:37

    hallo
    da mein formular nach dem update keine umlaute mehr versendet, habe ich hier im forum gelesen, dass man auf UTF-8 umstellen sollte. frage: was ist alles zu tun?

    ins setup habe ich geschrieben:

    1. page.config.metaCharset = utf-8
    2. page.config.doctype = xhtml_trans

    im installtool unter All Configuration habe ich folgendes auf UTF-8 gesetzt:

    -[GFX][TTFLocaleConv]= UTF-8

    -[SYS][setDBinit]= SET NAMES utf8; | SET SESSION character_...
    SET NAMES utf8;
    SET SESSION character_set_server=utf8;

    -[BE][forceCharset]= UTF-8

    ...dann erhielt ich die fehlermeldung:
    Oops, an error occured!
    Forced charset not found: The forced character set "UTF-8" was not found in t3lib/csconvtbl/

    was muss ich weiter tun damit es funktioniert?
    muss ich die DB manuell auf UTF-8 stellen?
    dank und gruss
    andré


  • 1
  • andimohr andimohr
    Padawan
    0 x
    47 Beiträge
    0 Hilfreiche Beiträge
    03. 05. 2011, 12:14

    Da bin ich lelich auch durch. Das sind meine Notizen, ich hoffe die helfen dir in dem einen oder anderen Punkt weiter... eventuell fehlen bei dir in der Konf nur Anführungszeichen oder Semikolon...

    *******************
    Update All Extensions
    *******************

    *******************
    Umstellen uf utf8 !
    *******************

    Vorab prüfen ob phpmysqladmin anzeige utf8

    character encoding of the database is as recommended: utf8_general_ci
    exported it and imported the latin1 data into a new utf8 database.
    1.) Template -> TypoScript Object Browser...

    Constants Umlaute?
    Setup Umlaute?
    Alle Templates und Externen Skripte nach Umlauten durchsuchen

    2.) Backup Database

    3.) Dump Database ohne Schema, wichtige spezielle Parameter siehe D:\mysql50scripsmig

    4.) php.ini
    default_charset = "utf-8"

    5.) my.ini
    [mysql]und [mysqld]default-character-set=utf8

    6.) localconf.php

    // For backend charset
    $TYPO3_CONF_VARS['BE']['forceCharset'] = 'utf-8';
    $TYPO3_CONF_VARS['SYS']['setDBinit'] = 'SET NAMES utf8;';

    // For GIFBUILDER support
    // Set it to 'iconv' or 'mbstring'
    $TYPO3_CONF_VARS['SYS']['t3lib_cs_convMethod'] = 'mbstring';
    // For 'iconv' support you need at least PHP 5.
    $TYPO3_CONF_VARS['SYS']['t3lib_cs_utils'] = 'mbstring';

    Empty exisitng Database (truncate all tables)

    7.) db_utf8_fix.php
    http://wiki.typo3.org/wiki/UTF-8_support#Introduction
    ggf. Zeile 97 - 107 auskommentieren
    stellt alle Tabellen auf utf8 um, Inhalte werden möglicherweise Truncated

    8.) In Typo3 BE phpMyAdmin - Clear all Tables (Truncate)

    9.) Import from .sql dump ohne Schema
    Ergänzen: use `typo3db`;

    10.) Im Typo3 BE Clear all table Caches

    11.) Reboot

    You have to rebuild the reference index afterwards!

  • 1